summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-04-23 13:25:46 +0200
committerGuix Patches Tester <>2024-04-23 13:37:14 +0200
commita4faeae49305a5e11a270df5a626dfe49af80efa (patch)
tree35f205d6290c8886f7cf9038237cbfe47ee0a9cd
parent2616c3bb945b7c3c3633affdbdbfbaccddad7d90 (diff)
downloadguix-patches-issue-70535.tar
guix-patches-issue-70535.tar.gz
gnu: Add r-metadeconfoundr.issue-70535
* gnu/packages/cran.scm (r-metadeconfoundr): New variable. Change-Id: I733fb464d2a3c7fd1335826be9f23e2610e6fd60
-rw-r--r--gnu/packages/cran.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 57dabc8ec3..46749aa714 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -41612,6 +41612,47 @@ purposes, illustrating/testing meta-analytic methods, and validating published
analyses.")
(license license:gpl2+)))
+(define-public r-metadeconfoundr
+ ;; There are some consistent updates after the release of version 0.3.0.
+ (let ((commit "90aec0226c5128bfcbbc08903452eff460d21424")
+ (revision "1"))
+ (package
+ (name "r-metadeconfoundr")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TillBirkner/metadeconfoundR")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zkqar27p5qwq46xbxsw5x1pl50xbkgqiizw5bydlyhwb0ga2f3h"))))
+ (properties `((upstream-name . "metadeconfoundR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bigmemory
+ r-detectseparation
+ r-doparallel
+ r-dosnow
+ r-foreach
+ r-futile-logger
+ r-ggplot2
+ r-lme4
+ r-lmtest
+ r-reshape2
+ r-snow))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/TillBirkner/metadeconfoundR")
+ (synopsis "Check multiple covariates for potenial confounding effects")
+ (description
+ "This package detects naive associations between omics features and
+metadata in cross-sectional data-sets using non-parametric tests. In a second
+step, confounding effects between metadata associated to the same omics feature
+are detected and labeled using nested post-hoc model comparison tests. The
+generated output can be graphically summarized using the built-in plotting
+function.")
+ (license license:gpl2))))
+
(define-public r-mathjaxr
(package
(name "r-mathjaxr")