summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-04-22 21:45:45 +0800
committerGuix Patches Tester <>2024-04-22 15:54:52 +0200
commitcd27fa10ea08a02a554e9df22b47ea32734506e7 (patch)
treec975f348e8573392baffebfa206d3a8eb40d3fc9
parentaf4db17122d759705f3fd0ab03ef36c76ec90338 (diff)
downloadguix-patches-issue-70514.tar
guix-patches-issue-70514.tar.gz
gnu: retroarch: Fix OpenGL core and Vulkan drivers.issue-70514
* gnu/packages/emulators.scm (retroarch)[arguments]: Ignore check result for HAVE_GLSLANG_HLSL in the configure phase. Change-Id: I3ba110b834acca25ada0e680a6bcb879b4db96f4
-rw-r--r--gnu/packages/emulators.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a935808da5..08894bd685 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1462,6 +1462,10 @@ as RetroArch.")
(("/usr/local/share/wayland-protocols")
(string-append wayland-protocols "/share/wayland-protocols")))
+ ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
+ (substitute* "qb/config.libs.sh"
+ (("[$]HAVE_GLSLANG_HLSL") "notcare"))
+
;; The configure script does not yet accept the extra arguments
;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
(invoke