summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuval Langer <yuval.langer@gmail.com>2024-04-19 05:22:08 +0300
committerGuix Patches Tester <>2024-04-19 12:25:47 +0200
commitc55e076351677de580cac2d7d4cb54f32dfbb428 (patch)
tree0b8eb4ca5f0df54d7716bc81f58c101d0f7017bf
parent2126dab4cd81db4cbde4566d8c638e45a4c0077c (diff)
downloadguix-patches-issue-70467.tar
guix-patches-issue-70467.tar.gz
Add the Texinfo adaptation of the R7RS-small Scheme standard.issue-70467
-rw-r--r--gnu/packages/scheme.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index a91a2d693d..9177801800 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1314,3 +1314,47 @@ as well as light. The implementation is based on an ad-hoc Virtual
Machine. STklos can also be compiled as a library and embedded in an
application.")
(license gpl2+)))
+
+(define-public r7rs-small-texinfo
+ (let ((commit "38a703976ea6353e32b52a5187dbdaf77fb2f050")
+ (revision "2"))
+ (package
+ (name "r7rs-small-texinfo")
+ (version (git-version "0.1.0" revision commit))
+ (home-page "https://codeberg.org/Zipheir/r7rs-small-texinfo/")
+ (source
+ (origin
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fr02fyhiwd364jkfy1n5w31pq3kx1rl5w634421g05702yb47x3"))))
+ (native-inputs (list bash texinfo))
+ (inputs '())
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'compile-the-files
+ (lambda _
+ (let* ((source-directory-path (string-append (getcwd)
+ "/doc/r7rs-small"))
+ (build-script-path (string-append
+ source-directory-path
+ "/build.sh"))
+ (info-directory-path (string-append #$output
+ "/share/info")))
+ (chdir source-directory-path)
+ (system* "bash" build-script-path "info")
+ (mkdir-p info-directory-path)
+ (copy-file (string-append source-directory-path
+ "/r7rs-small.info")
+ (string-append info-directory-path
+ "/r7rs-small.info"))))))))
+ (synopsis
+ "R7RS Small standard of the Scheme programming language in Info format")
+ (description
+ "Revised^7 Report of the Algorithmic Language Scheme adapted to Texinfo format.")
+ (license (non-copyleft "file://COPYING")))))