summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Pieper <jpieper@mailbox.org>2024-04-15 19:45:10 +0200
committerGuix Patches Tester <>2024-04-17 14:14:54 +0200
commita025e4c4c9d93e391b29cf53e03253926266eb9e (patch)
treeb59a1ce98cd6801b2770a39d46339724e240871d
parent327823c2a36e74f57e7b2bb8fbbbc243d12f4ece (diff)
downloadguix-patches-issue-70400.tar
guix-patches-issue-70400.tar.gz
gnu: python-lsp-server: Update to 1.11.0.issue-70400
* gnu/packages/python-xyz.scm (python-lsp-server): Update to 1.11.0. [build-system]: Change to pyproject-build-system. [arguments]{set-version}: Set version explicitly to pass sanity-check. {check}: Do not replace it as test_pyqt_completion is no longer failing. [propagated-inputs]: Remove python-future and add python-docstring-to-markdown. [native-inputs]: Remove python-mock, python-versioneer and add python-whatthepatch, python-pyqt. Change-Id: I937730caaae394141af13881a107157868b18bab
-rw-r--r--gnu/packages/python-xyz.scm75
1 files changed, 37 insertions, 38 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0d78e56d5e..94ae0e2194 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -152,6 +152,7 @@
;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2024 TakeV <takev@disroot.org>
+;;; Copyright © 2024 Jonathan Pieper <jpieper@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7874,53 +7875,51 @@ Server (PLS).")
(define-public python-lsp-server
(package
(name "python-lsp-server")
- (version "1.3.3")
+ (version "1.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-lsp-server" version))
(sha256
- (base32
- "0h6wxzmm6qjfwkkn3mnzn1fpmcp23fpbk74bi8p540q1nzccqj0v"))))
- (build-system python-build-system)
+ (base32 "11lf7c9dpf8jzz5y7dllz8l1lka887m9a79xbazy8lkq7zxxdvc9"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp")))
- (replace 'check
- (lambda _
- ;; Disable failing test.
- (invoke "python" "-m" "pytest" "-k"
- "not test_pyqt_completion"))))))
- (propagated-inputs
- (list python-autopep8
- python-pydocstyle
- python-flake8
- python-future
- python-jedi
- python-lsp-jsonrpc
- python-pluggy
- python-pycodestyle
- python-pyflakes
- python-rope
- python-ujson
- python-yapf))
- (native-inputs
- (list python-coverage
- python-flaky
- python-matplotlib
- python-mock
- python-numpy
- python-pandas
- python-pylint
- python-pytest
- python-pytest-cov
- python-versioneer))
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-version
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("dynamic = \\[\"version\"\\]")
+ (string-append "version = \""
+ ,version "\"")))))
+ (add-before 'check 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list python-autopep8
+ python-docstring-to-markdown
+ python-pydocstyle
+ python-flake8
+ python-jedi
+ python-lsp-jsonrpc
+ python-pluggy
+ python-pycodestyle
+ python-pyflakes
+ python-rope
+ python-ujson
+ python-yapf))
+ (native-inputs (list python-coverage
+ python-flaky
+ python-matplotlib
+ python-numpy
+ python-pandas
+ python-pylint
+ python-pyqt
+ python-pytest
+ python-pytest-cov
+ python-whatthepatch))
(home-page "https://github.com/python-lsp/python-lsp-server")
(synopsis "Python implementation of the Language Server Protocol")
(description
-"The Python Language Server @command{pylsp} is an implementation of the
+ "The Python Language Server @command{pylsp} is an implementation of the
Python 3 language specification for the Language Server Protocol (LSP).
This tool is used in text editing environments to provide a complete
and integrated feature-set for programming Python effectively.")