summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoé Lopez <noelopez@free.fr>2024-04-14 00:42:56 +0200
committerGuix Patches Tester <>2024-04-17 14:12:19 +0200
commit13c1f84a9ef77217a8725085228df4c181c36916 (patch)
tree4ef6ab20051488aac61c6686dc2695f72cb06c90
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70374.tar
guix-patches-issue-70374.tar.gz
gnu: Add emacs-smudge.issue-70374
Change-Id: I152b1cb0127a30aa49e9edd26e8ad3e8d728cd29
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5da3f28545..1d5d801b58 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24278,6 +24279,30 @@ orient yourself in the code, and tell which statements are at a given level.")
"This package allows controlling Pulseaudio from Emacs.")
(license license:gpl3+))))
+(define-public emacs-smudge
+ (let ((commit "4a9c5b34e9bc0a694d0faf8c2f83dc244b8b6a2f")
+ (revision "4"))
+ (package
+ (name "emacs-smudge")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danielfm/smudge.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xiqxw87sdk9mgy7fdbmzqaf58dc1grhkigirg1bd0b2q5kbnbwx"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-simple-httpd emacs-request emacs-oauth2))
+ (home-page "https://github.com/danielfm/smudge")
+ (synopsis "Control the Spotify app from within Emacs")
+ (description "Smudge allows you to control the Spotify application
+from Emacs. Either via D-BUS or Spotify Connect if you have a Spotify
+premium subscription.")
+ (license license:gpl3))))
+
(define-public emacs-pulsar
(package
(name "emacs-pulsar")