summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-11 15:09:17 +0100
committerGuix Patches Tester <>2024-04-17 13:58:55 +0200
commit10ff67fa6e97ebed5843e521ae9c8f99bc738fe5 (patch)
tree845c404177b0192478ce18441570701816146cf4
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70340.tar
guix-patches-issue-70340.tar.gz
gnu: Add restool.issue-70340
* gnu/packages/linux.scm (restool): New variable. Change-Id: I40fae10c96460a8e7cc86419ed7bb9633aca66e6
-rw-r--r--gnu/packages/linux.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9c819838bd..00a451699c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10229,6 +10229,60 @@ through standard log mechanisms like syslog.")
calls the Linux-specific @code{renameat2} system call.")
(license license:expat))))
+(define-public restool
+ (let ((revision "0")
+ (commit "46604e41f4c7e54efa62503c6b4629321b21e056"))
+ (package
+ (name "restool")
+ (version (git-version "2.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nxp-qoriq/restool.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1vp86iprdla7fc95lfvjq8wfzwbm2mdy0dil04jvvdz6kq6yyn4j"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output)
+ (string-append "bindir_completion=" #$output
+ "/share/bash-completion/completions"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'install 'wrap-scripts
+ (lambda _
+ (for-each
+ (lambda (file)
+ (wrap-program (string-append #$output "/bin/" file)
+ `("PATH" prefix
+ (,(string-append #$output "/bin")))))
+ '("ls-append-dpl" "ls-debug" "ls-main"))))
+ #$@(if (not (or (target-x86-64?) (target-x86-32?)))
+ #~((add-after 'unpack 'remove-manpage
+ (lambda _
+ (substitute* "Makefile"
+ (("scripts/restool_completion.sh \\$\\(MANPAGE\\)")
+ "")
+ (("install -m 0644 -D \\$\\(MANPAGE\\) .*") "")))))
+ #~()))))
+ (native-inputs
+ (if (or (target-x86-64?) (target-x86-32?))
+ (list pandoc)
+ '()))
+ (synopsis "Manage DPAA2 containers and objects")
+ (description "This package provides restool, a user space application to
+dynamically create and manage DPAA2 containers and objects.")
+ (supported-systems (delete "i586-gnu" %supported-systems))
+ (home-page "https://github.com/nxp-qoriq/restool")
+ (license license:bsd-3))))
+
(define-public libgpiod
(package
(name "libgpiod")