summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-04-21 17:02:18 +0000
committerGuix Patches Tester <>2024-04-21 20:07:37 +0200
commitdb57b25570610b5be12f76babced93c3c8271bc6 (patch)
treede43c5bb00b63d1ddbc458f42308a9a9c85c806b
parent43a4215cad8c6da357f895569c0cedf5e854cee0 (diff)
downloadguix-patches-issue-70282.tar
guix-patches-issue-70282.tar.gz
gnu: gnome-shell: Wrap screencast service.issue-70282
Adjust screencast such that GI_TYPELIB_PATH and GST_PLUGIN_SYSTEM_PATH are set before starting. Add all required gstreamer plugins to inputs. To be able to use it a running pipewire service is needed. * gnu/packages/gnome.scm (gnome-shell): [inputs]: Add gst-plugins-good and pipewire. [#:phases]<'wrap-programs>: Wrap org.gnome.Shell.Screencast. Change-Id: I2c31bf1bd92e281b86c57b06988c6a3793a58d40
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 489f23865b..b3c3fb72ad 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9392,6 +9392,7 @@ properties, screen resolution, and other GNOME parameters.")
(add-after 'install 'wrap-programs
(lambda* (#:key inputs #:allow-other-keys)
(let ((gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
(python-path
(string-join
(filter (lambda (item)
@@ -9411,6 +9412,18 @@ properties, screen resolution, and other GNOME parameters.")
"path => imports.gi.GIRepository.Repository."
"prepend_search_path(path));\n"
all)))
+ ;; Screencast requires a pipewire service running
+ ;; (i.e. as provided by home-pipewire-service-type)
+ (substitute* (string-append #$output "/share/gnome-shell/"
+ "org.gnome.Shell.Screencast")
+ (("imports\\.package\\.start" all)
+ (string-append "'" gi-typelib-path "'.split(':').forEach("
+ "path => imports.gi.GIRepository.Repository."
+ "prepend_search_path(path));\n"
+ "imports.gi.GLib.setenv('GST_PLUGIN_SYSTEM_PATH',"
+ "'" gst-plugin-path "'"
+ ", true);\n"
+ all)))
(for-each
(lambda (prog)
(wrap-program (string-append #$output "/bin/" prog)
@@ -9476,6 +9489,7 @@ printf '~a is deprecated. Use the \"gnome-extensions\" CLI or \
gnome-settings-daemon
graphene
gst-plugins-base
+ gst-plugins-good
ibus
libcanberra
libcroco
@@ -9486,6 +9500,7 @@ printf '~a is deprecated. Use the \"gnome-extensions\" CLI or \
mesa-headers
mutter
network-manager-applet
+ pipewire
polkit
pulseaudio
python-pygobject