summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-04-08 00:13:02 +0200
committerGuix Patches Tester <>2024-04-17 14:19:56 +0200
commit4da077b92059878036c28dc30d79e0dfd5f0f9dd (patch)
treeef2edf7f5e616d9fb470d0b268cd634a2acea6d9
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70269.tar
guix-patches-issue-70269.tar.gz
gnu: Add python-pybadges.issue-70269
* gnu/packages/python-web.scm (python-pybadges): New variable. Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
-rw-r--r--gnu/packages/python-web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5a532f8460..e751d45b1e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9143,6 +9143,40 @@ list, create, update, or delete resources (e.g. Order, Product, Collection).")
"This package provides a library to parse and apply patches.")
(license license:expat)))
+(define-public python-pybadges
+ (package
+ (name "python-pybadges")
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/pybadges")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~'("-k"
+ ;; Disable network dependent tests.
+ "not test_changes and not test_not_image_url and not test_http_url")))
+ (propagated-inputs (list python-jinja2 python-requests))
+ (native-inputs (list python-flask
+ python-fonttools
+ python-nox
+ python-pillow
+ python-pytest
+ python-xmldiff))
+ (home-page "https://github.com/google/pybadges")
+ (synopsis
+ "Libbrary and command-line tool for generating Github-style badges")
+ (description
+ "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges.")
+ (license license:asl2.0)))
+
(define-public python-grid5000
(package
(name "python-grid5000")