summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi via Guix-patches via <guix-patches@gnu.org>2024-04-17 10:34:44 +0100
committerGuix Patches Tester <>2024-04-17 14:24:08 +0200
commitce8a14bd69427a61f0a96ee6999ae3d5f432926e (patch)
tree72afacd8b57e5ea5a2866990b4e4235ea384cf5c
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70268.tar
guix-patches-issue-70268.tar.gz
gnu: Add python-vdf.issue-70268
* gnu/packages/python-xyz.scm (python-vdf): New variable. Reviewed-by: Steve George <steve@futurile.net> Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..1637f2aa8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6834,6 +6834,24 @@ text styles of documentation.")
"Pygments is a syntax highlighting package written in Python.")
(license license:bsd-2)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Work with Valve's VDF text format")
+ (description "This package provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+ (license license:expat)))
+
(define-public python-pygments-github-lexers
(package
(name "python-pygments-github-lexers")