summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-04-07 14:03:54 +0530
committerGuix Patches Tester <>2024-04-17 14:05:15 +0200
commit5d2bf9b23b8b68dd74fea27adc784fe37fa1897f (patch)
treeec89871c70e569689f0a5deadf96e8d362f0269e
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70253.tar
guix-patches-issue-70253.tar.gz
gnu: Add kmail-account-wizard.issue-70253
* gnu/packages/kde-pim.scm (kmail-account-wizard): New variable. Change-Id: I1648f588712ccfe5a8e34c16a92f440691d3af18
-rw-r--r--gnu/packages/kde-pim.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 5780b9dbca..e4ab27467c 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1329,6 +1329,55 @@ manager from KDE.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kmail-account-wizard
+ (package
+ (name "kmail-account-wizard")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kmail-account-wizard-" version ".tar.xz"))
+ (sha256
+ (base32 "1840zjgrqwk2zgqbb33gl9nvigsrmk5grzvzg5cw116h7lb7z7xx"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules shared-mime-info))
+ (inputs
+ (list akonadi
+ akonadi-mime
+ kcrash
+ kross
+ kcmutils
+ kdbusaddons
+ kiconthemes
+ kidentitymanagement
+ kimap
+ kitemmodels
+ kldap
+ kmailtransport
+ kmime
+ knewstuff
+ knotifications
+ knotifyconfig
+ kpimcommon
+ kpimtextedit
+ ktextaddons
+ ktexteditor
+ kwallet
+ libkdepim
+ libkleo
+ qtkeychain
+ qtscript
+ qttools-5))
+ (home-page "https://invent.kde.org/pim/kmail-account-wizard")
+ (synopsis "Assistant for the configuration of accounts in KMail")
+ (description
+ "This package provides an assistant for the configuration of accounts in
+KMail.")
+ (license ;;GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
(define-public kmailcommon
(package
(name "kmailcommon")