summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-04-06 16:49:22 +0000
committerGuix Patches Tester <>2024-04-17 14:26:52 +0200
commit8967a707758e720a744cd7fc0cdfbac9a2507c3f (patch)
tree9ab64b7ac84e84468a36d87974e28cb0653baf3b
parent276265477e87cc721448cf369030921c040e35bb (diff)
downloadguix-patches-issue-70242.tar
guix-patches-issue-70242.tar.gz
gnu: blender: Add optional dependencies.issue-70242
* gnu/packages/graphics.scm (blender)[inputs]: Add alembic, libharu, libspnav, libwebp, llvm, materialx, openshadinglanguage, openxr, potrace, pulseaudio, sdl2. Change-Id: Ic6354df6623781d08876dc8aa1f89065e07f92f6
-rw-r--r--gnu/packages/graphics.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d45b675a19..064044070a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -70,6 +70,7 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages engineering)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -546,7 +547,8 @@ typically encountered in feature film production.")
"/lib/python" #$python-version
"/site-packages/")))))
(inputs
- (list boost
+ (list alembic
+ boost
bullet
eigen
embree
@@ -560,24 +562,34 @@ typically encountered in feature film production.")
jack-1
jemalloc
libepoxy
+ libharu
libjpeg-turbo
libpng
libsndfile
+ libspnav
libtiff
+ libwebp
libx11
libxi
libxrender
+ llvm
lzo
+ materialx
openal
opencolorio
openexr
openimageio
openjpeg
+ openshadinglanguage
opensubdiv
openvdb
+ openxr
+ potrace
pugixml
+ pulseaudio
python
python-numpy
+ sdl2
tbb
zlib
`(,zstd "lib")))