summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-04-06 08:24:00 -0700
committerGuix Patches Tester <>2024-04-17 14:05:28 +0200
commit11b48fa5f04bbdfa51de9a5b9e5866b14a0a2d47 (patch)
treeb1d9545437dcaed4b6c38d94e6081fe2c34528fc
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70240.tar
guix-patches-issue-70240.tar.gz
gnu: uefitool: Add extra outputs, correct typoissue-70240
* gnu/packages/flashing-tools.scm (uefitool): Add UEFIPatch and UEFIReplace in addition to UEFITool; add outputs for them. Correct package description. Change-Id: I45ca03a71c463c91ab11e9dcd47971afc06724b7
-rw-r--r--gnu/packages/flashing-tools.scm46
1 files changed, 34 insertions, 12 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 83a4c3e3e7..3787e9d32a 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -493,29 +493,51 @@ ME as far as possible (it only edits ME firmware image files).")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/LongSoft/UEFITool")
- (commit version)))
+ (url "https://github.com/LongSoft/UEFITool")
+ (commit version)))
(sha256
(base32
"1n2hd2dysi5bv2iyq40phh1jxc48gdwzs414vfbxvcharcwapnja"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (outputs '("out" "uefipatch" "uefireplace"))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "qmake" "-makefile")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "UEFITool" (string-append (assoc-ref outputs "out")
- "/bin")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "qmake" "-makefile")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "UEFITool" (string-append (assoc-ref outputs "out")
+ "/bin"))))
+ (add-after 'configure 'configure-extras
+ (lambda _
+ (with-directory-excursion "UEFIPatch"
+ (invoke "qmake" "-makefile"))
+ (with-directory-excursion "UEFIReplace"
+ (invoke "qmake" "-makefile"))))
+ (add-after 'build 'build-extras
+ (lambda _
+ (with-directory-excursion "UEFIPatch"
+ (invoke "make" "-j"))
+ (with-directory-excursion "UEFIReplace"
+ (invoke "make" "-j"))))
+ (add-after 'install 'install-extras
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "UEFIPatch/UEFIPatch"
+ (string-append (assoc-ref outputs "uefipatch")
+ "/bin"))
+ (install-file "UEFIReplace/UEFIReplace"
+ (string-append (assoc-ref outputs "uefireplace")
+ "/bin")))))))
(inputs
(list qtbase-5))
(home-page "https://github.com/LongSoft/UEFITool/")
(synopsis "UEFI image editor")
(description "@code{uefitool} is a graphical image file editor for
-Unifinished Extensible Firmware Interface (UEFI) images.")
+Unified Extensible Firmware Interface (UEFI) images.")
(license license:bsd-2)))
(define-public srecord