summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-04-06 00:47:19 +0000
committerGuix Patches Tester <>2024-04-17 14:11:12 +0200
commit149698ee64bdcdb947364f75a75b582da28651c0 (patch)
tree1a45096cc2880cdc1ba4b35709bf2c83694b8aa8
parent22fc032b9bdcf90d82118339e52d9dd691db89ad (diff)
downloadguix-patches-issue-70224.tar
guix-patches-issue-70224.tar.gz
gnu: toxic: Update to 0.15.1.issue-70224
* gnu/packages/messaging.scm (toxic): Update to 0.15.1. [arguments]: Use G-Expressions. <#:make-flags>: Use gexp variables and cc-for-target. <#:phases>: Remove trailing #t. Change-Id: If1d46888e26b16ffcbbca48dc2c88b921e30c433
-rw-r--r--gnu/packages/messaging.scm38
1 files changed, 17 insertions, 21 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 919ae6aaa7..83463f44c6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2294,7 +2294,7 @@ building the IRC clients and bots.")
(define-public toxic
(package
(name "toxic")
- (version "0.8.4")
+ (version "0.15.1")
(source
(origin
(method git-fetch)
@@ -2302,29 +2302,25 @@ building the IRC clients and bots.")
(url "https://github.com/JFreegman/toxic")
(commit (string-append "v" version))))
(sha256
- (base32 "0p1cmj1kyp506y5xm04mhlznhf5wcylvgsn6b307ms91vjqs3fg2"))
+ (base32 "1cbgw9my7nd8b215a3db2jc74nibi9kj0yk5q3c9dnh306as6wzs"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list
- "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'enable-python-scripting
- (lambda _
- ;; XXX: For compatibility with Python 3.8, adjust python3-config
- ;; invokation to include --embed; see
- ;; <https://github.com/JFreegman/toxic/issues/533>.
- (substitute* "cfg/checks/python.mk"
- (("python3-config --ldflags")
- "python3-config --ldflags --embed"))
- (setenv "ENABLE_PYTHON" "1")
- #t)))))
+ (list #:tests? #f ; no tests
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'enable-python-scripting
+ (lambda _
+ ;; XXX: For compatibility with Python 3.8, adjust
+ ;; python3-config invocation to include --embed; see
+ ;; <https://github.com/JFreegman/toxic/issues/533>.
+ (substitute* "cfg/checks/python.mk"
+ (("python3-config --ldflags")
+ "python3-config --ldflags --embed"))
+ (setenv "ENABLE_PYTHON" "1"))))))
(inputs
(list c-toxcore
curl