summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-03-30 12:42:41 +0100
committerGuix Patches Tester <>2024-04-17 13:58:11 +0200
commit3d2c8c07127eede3b0e1af3bf1a4cc6ea29fc94f (patch)
tree34bd5faa60a3e7e8643dbd2c77bcd62686317d3b
parent944eb58ecb12ff3e0a14ac63085cc9b886266aed (diff)
downloadguix-patches-issue-70087.tar
guix-patches-issue-70087.tar.gz
gnu: minizinc: Update to 2.8.3.issue-70087
* gnu/packages/maths.scm (minizinc): Update. Change-Id: I503fd004b38abaac8829a2cb94c182b001d83763
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ed16042ddd..f81f5082dc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4035,7 +4035,7 @@ book.")
(define-public minizinc
(package
(name "minizinc")
- (version "2.5.5")
+ (version "2.8.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4044,7 +4044,7 @@ book.")
(file-name (git-file-name name version))
(sha256
(base32
- "10b2hsl1fx9psh0iagmp8ki3f60f3qg5hmvra5aczjlfmbl88ggp"))
+ "1h3pc92m7ypvmhrrhk2263ib5rqc4fv4n6lai0p8dwiidjpcqnpz"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -4090,6 +4090,9 @@ book.")
"MIP_solverinstance.cpp"
"MIP_wrap.cpp")))
(scandir "."))))
+ ;; Gecode 6.3 does not yet support new interface.
+ (substitute* "solvers/gecode/gecode_solverinstance.cpp"
+ (("600300") "600400"))
(substitute* "CMakeLists.txt"
(("find_package\\(([^ ]*).*\\)" all pkg)
(if (member pkg '("Gecode" "OsiCBC" "Threads"))