summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2024-03-29 09:57:59 +0100
committerGuix Patches Tester <>2024-04-17 13:54:02 +0200
commitcba0147b27978a8e4c30d4c2ff68aa174da8152f (patch)
tree0e321b2f018a8321cfab88413b60b7f8c4d832fe
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70067.tar
guix-patches-issue-70067.tar.gz
gnu: Add python-find-libpython.issue-70067
* gnu/packages/python-xyz.scm (python-find-libpython): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..951de46d8b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21050,6 +21050,29 @@ capable of parsing almost any programming language out there, and to
some degree most natural languages too.")
(license license:expat)))
+(define-public python-find-libpython
+ (package
+ (name "python-find-libpython")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ktbarrett/find_libpython")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z1r9nix2z75sv41j97pnl6jgj2lk6k8la23vavxjpprsc9ld1dd"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/ktbarrett/find_libpython")
+ (synopsis "Find the path to the @code{libpython} dynamic library")
+ (description "@code{find_libpython} helps find the path to the
+@code{libpython} dynamic library for the current Python environment. It is
+both a script and a Python package.")
+ (license license:expat)))
+
(define-public python-libcst
(package
(name "python-libcst")