summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSkyler Ferris <skyvine@protonmail.com>2024-03-25 19:16:14 +0000
committerGuix Patches Tester <>2024-04-17 13:52:35 +0200
commit8f0c606065e7f549c72248520fbf25dbde0616ec (patch)
tree389d7ea25842a994ef5ffa620cdd331f1c1cbdad
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70001.tar
guix-patches-issue-70001.tar.gz
gnu: reprotest: Add missing propogated inputsissue-70001
* gnu/packages/diffoscope.scm (reprotest): Add bash, coreutils, diffoscope, disorderfs, findutils, grep, inetutils, libfaketime, and util-linux as propagated inputs. Change-Id: Ibc113558032697be9048bebe54ba7678156667b9
-rw-r--r--gnu/packages/diffoscope.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 8106a6d258..cc5bef572e 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -29,12 +29,14 @@
#:use-module (gnu packages android)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bootloaders)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpio)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gnome)
@@ -265,6 +267,18 @@ install.")
(base32 "1992wlkil07fmj64lw3i7l16dgkkzphz0f932hbkkj9rlcamdwxd"))))
(inputs
(list python-debian python-distro python-libarchive-c python-rstr))
+ (propagated-inputs
+ (list
+ bash ; the python code sets up shell scripts to be executed
+ coreutils ; tests: locale, exec_path, home ("env")
+ diffoscope ; used to display diffs when builds are not reproducible
+ disorderfs ; test: fileordering, but fuse-2 and sudo must be installed as
+ ; setuid programs as well.
+ findutils ; __init__ uses "find" to get the hash of multiple files
+ grep ; tests: kernel
+ inetutils ; tests: domain_host ("hostname")
+ libfaketime ; tests: time
+ util-linux)) ; tests: num_cpus ("taskset")
(native-inputs
`(("diffoscope" ,diffoscope)
("help2man" ,help2man)