summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-04-16 14:34:01 +0200
committerGuix Patches Tester <>2024-04-17 14:06:10 +0200
commit88e231d39643e117c58b14f0f632a36eb0127d35 (patch)
tree0a22d6039b08a9ac6302c35d7e1f4a735f777fef
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-69817.tar
guix-patches-issue-69817.tar.gz
gnu: Add python-pynsee.issue-69817
* gnu/packages/python-science.scm (python-pynsee): New variable. Change-Id: I4e93d26ad4b6be238b0e4cce82ea77030caf6e02
-rw-r--r--gnu/packages/python-science.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 862e101f6a..1d902d23f2 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2649,6 +2650,37 @@ visualization and image processing involving N-dimensional raster data) into
and from numpy arrays.")
(license license:expat)))
+(define-public python-pynsee
+ (package
+ (name "python-pynsee")
+ (version "0.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynsee" version))
+ (sha256
+ (base32 "0wd1xhkjpll8mzrrhnqxrand32p338j2zfw3h1gxacf31iwxhips"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ; XXX: Tests require network access.
+ (propagated-inputs (list python-appdirs
+ python-pandas
+ python-requests
+ python-shapely
+ python-tqdm
+ python-unidecode
+ python-urllib3))
+ (home-page "https://pynsee.readthedocs.io")
+ (synopsis
+ "Tools to Easily Search and Download French Data From INSEE and IGN APIs")
+ (description
+ "This package provides tools to easily search and download French data
+from INSEE and IGN APIs. This data includes more than 150 000 macroeconomic
+series, a dozen datasets of local french data, numerous sources available on
+@url{insee.fr}, geographical limits of administrative areas taken from IGN as
+well as key metadata and SIRENE database containing data on all French
+compagnies.")
+ (license license:expat)))
+
(define-public python-libneuroml
(package
(name "python-libneuroml")