summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-05-25 12:17:30 +0800
committerGuix Patches Tester <>2024-05-25 06:35:49 +0200
commitd7f6aea266fbf36735cbea60f85a88dec618a17f (patch)
treecfb55bc125585a2dd18217eb08f378abded3fc5f
parent016fd7720db06f0945e345cc9d5043642f3b8720 (diff)
downloadguix-patches-issue-69504.tar
guix-patches-issue-69504.tar.gz
gnu: Add wbg.issue-69504
* gnu/packages/wm.scm (wbg): New variable. Change-Id: Ib20af5fee37ab258224ead6caf35af3b9c78e802
-rw-r--r--gnu/packages/wm.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8f74076cfd..c5194de1fc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -72,6 +72,7 @@
;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3905,3 +3906,34 @@ configuration."))))
for short) for X11 and Wayland, that goes to great lengths to be both CPU and
battery efficient---polling is only done when absolutely necessary.")
(license license:expat)))
+
+(define-public wbg
+ ;; This commit fixes a build error: https://codeberg.org/dnkl/wbg/issues/11
+ (let ((commit "dd36cce8c47bb0e17a789cf2bd95a51e29b59e78")
+ (revision "0"))
+ (package
+ (name "wbg")
+ (version (git-version "1.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/dnkl/wbg")
+ (commit commit)))
+ (sha256
+ (base32 "0nsb8w3myprhnwr59i6g4nwkc8fx67d40l70svjmwfmhpqy6zc18"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:build-type "release"
+ #:configure-flags #~(list "-Dpng=enabled"
+ "-Djpeg=enabled"
+ "-Dwebp=enabled")))
+ (native-inputs (list pkg-config tllist wayland-protocols))
+ (inputs (list libjpeg-turbo libpng libwebp pixman wayland))
+ (home-page "https://codeberg.org/dnkl/wbg")
+ (synopsis "Wallpaper application for Wayland compositors")
+ (description
+ "wbg is a super simple wallpaper application for Wayland compositors
+implementing the layer-shell protocol.")
+ (license license:expat))))