summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2024-04-20 11:09:10 -0400
committerGuix Patches Tester <>2024-04-20 18:23:16 +0200
commit39b5b3f4bc0242735c95ffc46ae697c25e7a5e46 (patch)
tree2934afc6c8a80bc6f6731dbf852de8d595f9f430
parent8600726d388da2c1e20820c8835953d6844a0d87 (diff)
downloadguix-patches-issue-69041.tar
guix-patches-issue-69041.tar.gz
gnu: Add m8c.issue-69041
Hello, Since initially submitting this patch, m8c has seen some updates. This new patch updates the package to the most recent version. Thanks, Juli * gnu/packages/electronics.scm (m8c): New symbol. Change-Id: Ibfc2e9364211e24c59d4d9015ab144f0c4ee972c
-rw-r--r--gnu/packages/electronics.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index aaf762b02b..e1451538c3 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -424,6 +425,47 @@ support for ESD sources.")
(home-page "https://xoscope.sourceforge.net/")
(license license:gpl2+)))
+(define-public m8c
+ (package
+ (name "m8c")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/laamaa/m8c")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wsknqgya2vkalbjq6rvmknsdk4lrqkn0z5rpjf4pd5vxgr8qryb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f)) ;no tests
+ (native-inputs (list pkg-config))
+ (inputs (list libserialport
+ sdl2))
+ (home-page "https://github.com/laamaa/m8c")
+ (synopsis "Cross-platform M8 tracker headless client")
+ (description
+ "The @url{https://dirtywave.com/products/m8-tracker,Dirtywave M8 Tracker}
+is a portable sequencer and synthesizer, featuring 8 tracks of assignable
+instruments such as FM, waveform synthesis, virtual analog, sample playback, and
+MIDI output. It is powered by a @url{https://www.pjrc.com/teensy/,Teensy}
+micro-controller and inspired by the Gameboy tracker
+@url{https://www.littlesounddj.com/lsd/index.php,Little Sound DJ}. m8c is a
+client for @url{https://github.com/Dirtywave/M8HeadlessFirmware,M8 Headless}
+which allows one to install the M8 firmware on any Teensy.")
+ (license (list license:cc-by-sa3.0
+ license:expat
+ license:public-domain
+ license:zlib))))
+
(define-public minipro
;; Information needed to fix Makefile
(let* ((commit "c181c2cf1619d00a520627d475e3fadb1eea5dac")