summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-06-09 09:35:07 +0000
committerGuix Patches Tester <>2024-06-09 12:59:32 +0200
commit511dc2ed385da14454bf7843e02cfd4c9c3e56ee (patch)
tree682b52c1c0666d53a28d43929d9242521fd68c83
parentbc8a41f4a8d9f1f0525d7bc97c67ed3c8aea3111 (diff)
downloadguix-patches-issue-67970.tar
guix-patches-issue-67970.tar.gz
gnu: python-pdfminer-six: Update to 20231228.issue-67970
* gnu/packages/python-xyz.scm (python-pdfminer-six): Update to 20231228. [build-system]: Use pyproject-build-system. [arguments]: Convert to gexp and remove custom 'check phase. [propagated-inputs]: Remove python-chardet and python-sortedcontainers; add python-charset-normalizer. [native-inputs]: Remove python-nose and python-tox; add python-pytest. Change-Id: I9913385a681b32afde930e32e7379db91357177b
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c22df7728a..b34caef16a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19926,7 +19926,7 @@ encoding algorithms to do fuzzy string matching.")
(define-public python-pdfminer-six
(package
(name "python-pdfminer-six")
- (version "20201018")
+ (version "20231228")
;; There are no tests in the PyPI tarball.
(source
(origin
@@ -19936,23 +19936,19 @@ encoding algorithms to do fuzzy string matching.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1a2fxxnnjqbx344znpvx7cnv1881dk6585ibw01inhfq3w6yj2lr"))))
- (build-system python-build-system)
+ (base32 "1anyr0gm7amwls8qifflql1viz5rq6q95lfwcg43v3180h4w8wrd"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Tests write to the source tree.
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (replace 'check
- (lambda _
- (invoke "make" "test"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests write to the source tree.
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files ".")))))))
(propagated-inputs
- (list python-chardet python-cryptography python-sortedcontainers))
+ (list python-charset-normalizer python-cryptography))
(native-inputs
- (list python-nose python-tox))
+ (list python-pytest))
(home-page "https://github.com/pdfminer/pdfminer.six")
(synopsis "PDF parser and analyzer")
(description "@code{pdfminer.six} is a community maintained fork of