summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2024-03-24 00:35:21 +0100
committerGuix Patches Tester <>2024-04-17 13:55:56 +0200
commit8572a2f3e6f45a9fd8777a4c092f447669bfd49e (patch)
treeeccf1a77f0dc68665fbcb88d1d16928edb03eb69
parent266f91283b7773390c3637bedbf2836be82a709f (diff)
downloadguix-patches-issue-64209.tar
guix-patches-issue-64209.tar.gz
gnu: Add ocaml-lsp-server.issue-64209
* gnu/packages/ocaml.scm (ocaml-lsp-server): New variable. Change-Id: Ib861dea3d7d00d570f253ffc3b4955e547dc2676
-rw-r--r--gnu/packages/ocaml.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index be8564f162..0aff46c779 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6226,6 +6226,48 @@ External contributors added support for Visual Studio Code, Sublime Text and
Atom.")
(license license:expat))))
+(define-public ocaml-lsp-server
+ (package
+ (name "ocaml-lsp-server")
+ (version "1.17.0")
+ (home-page "https://github.com/ocaml/ocaml-lsp")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (sha256
+ (base32
+ "1w1m2mi7va3wcwgvgzqd3af6hrhx5zzyr3hqa228pcimp44w6f0h"))))
+ (build-system dune-build-system)
+ (arguments '(#:tests? #f)) ; tests are failing for v1.17
+ (propagated-inputs (list
+ ocaml-re
+ ocaml-ppx-yojson-conv-lib
+ dune-rpc
+ ocaml-chrome-trace
+ dune-dyn
+ dune-stdune
+ ocaml-fiber
+ ocaml-xdg
+ dune-ordering
+ ocaml-dune-build-info
+ ocaml-spawn
+ ocamlc-loc
+ ocaml-uutf
+ ocaml-pp
+ ocaml-csexp
+ ocamlformat-rpc-lib
+ ocaml-odoc
+ ocaml-merlin-lib))
+ (native-inputs (list ocaml-ppx-expect ocamlformat))
+ (properties `((upstream-name . "ocaml-lsp-server")))
+ (synopsis "LSP Server for OCaml")
+ (description "This package implements an Ocaml language server implementation.")
+ (license license:isc)))
+
+(define-public ocaml5.0-lsp-server (package-with-ocaml5.0 ocaml-lsp-server))
+
(define-public ocaml-gsl
(package
(name "ocaml-gsl")