summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-05-11 09:59:43 -0700
committerGuix Patches Tester <>2024-05-11 19:18:10 +0200
commit93496a4c38b4a449d0fc9f9ac324d7bf53657815 (patch)
tree0655d7eff57492150ad3b1a22987e6673ed06b72
parent9288654773a110156e0bb6fc703a9c24f5bfc527 (diff)
downloadguix-patches-issue-62891.tar
guix-patches-issue-62891.tar.gz
gnu: Add quirrelissue-62891
* gnu/packages/squirrel.scm (quirrel): New variable Change-Id: I3b25604f7c5cc4f046a6421810e3928d5c5ba276
-rw-r--r--gnu/packages/squirrel.scm64
1 files changed, 63 insertions, 1 deletions
diff --git a/gnu/packages/squirrel.scm b/gnu/packages/squirrel.scm
index 1b9489882f..638f06ab8f 100644
--- a/gnu/packages/squirrel.scm
+++ b/gnu/packages/squirrel.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Li-cheng (Andy) Tai <atai@atai.org>
+;;; Copyright © 2019, 2023 Li-Cheng (Andy) Tai <atai@atai.org>
;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +22,7 @@
#:use-module (gnu packages sphinx)
#:use-module (guix build-system cmake)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build utils)
#:use-module (guix packages)
@@ -81,3 +82,64 @@ language, designed to be a light-weight scripting language that fits in the
size, memory bandwidth, and real-time requirements of applications like video
games.")
(license license:expat)))
+
+
+
+(define-public quirrel
+ (package
+ (name "quirrel")
+ (version "4.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GaijinEntertainment/quirrel.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18xvhssnh5lddi4ava7wzzvsiin8rh3vrbhcblv7l00qv0brh6gg"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags '("-DDISABLE_STATIC=ON")
+ #:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ ;; TODO: build and install doc files like squirrel above
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (include-dir (string-append out "/include")))
+ (mkdir-p include-dir)
+ (for-each (lambda (header-file)
+ (copy-recursively header-file
+ (string-append
+ include-dir "/"
+ (basename header-file))))
+ (find-files "../include"))) #t)))))
+ (native-inputs `(("cmake" ,cmake-minimal)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/GaijinEntertainment/quirrel")
+ (synopsis "Script language that is based on Squirrel language and is
+inspired by Python, Javascript and especially Lua")
+ (description
+ "Quirrel is a script language that is based on Squirrel language and is
+inspired by Python, Javascript and especially Lua, with
+@itemize
+@item Lexical scoping
+@item Higher order functions, closures and lambda
+@item Classes and inheritance
+@item Tail recursion
+@item Delegation
+@item String interpolation
+@item Exception handling
+@item Cooperative threads (coroutines)
+@item Generators
+@item Performance - Quirrel is fast and small (comparable with Lua and sometimes even faster)
+@item Both compiler and virtual machine fit together in about 13k lines of C++ code and add only around 100kb-150kb the executable size.
+@item Automatic memory management (CPU bursts free - reference counting and GC)
+@item Optional 16bits characters strings
+@item Dynamic typing type system is close to Javascript but stricter and simpler (there is integer type and no 'undefined')
+@item Powerful embedding api
+@item Modules
+@item Hot-reload (if you implement it in your code)
+@end itemize")
+ (license license:expat)))