summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHong Li <hli@mdc-berlin.de>2022-03-29 07:03:15 +0000
committerRicardo Wurmus <rekado@elephly.net>2022-04-06 11:43:46 +0200
commit730ac9ab85b4a7662558d5158b1a7e02afdd65c3 (patch)
tree7ebd289028cd187207aa1119fff998f9278469e5
parenta8182f386e6c4a0d9e1ab2f1eb3189a405c5d22c (diff)
downloadguix-patches-730ac9ab85b4a7662558d5158b1a7e02afdd65c3.tar
guix-patches-730ac9ab85b4a7662558d5158b1a7e02afdd65c3.tar.gz
gnu: Add r-stager.
* gnu/packages/bioconductor.scm (r-stager): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ffa38fda3a..ce1e23f0bf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4739,6 +4739,29 @@ events and allows for the incorporation of prior knowledge through supervised
graph construction.")
(license license:artistic2.0)))
+(define-public r-stager
+ (package
+ (name "r-stager")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "stageR" version))
+ (sha256
+ (base32 "0vpx0v04hgkhzi0bm7ipnb9xr37n5wvnnr45lljgni8pwabfkf6y"))))
+ (properties `((upstream-name . "stageR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/stageR")
+ (synopsis "Stage-wise analysis of high throughput gene expression data")
+ (description
+ "The stageR package allows automated stage-wise analysis of
+high-throughput gene expression data. The method is published in Genome
+Biology at
+@url{https://genomebiology.biomedcentral.com/articles/10.1186/s13059-017-1277-0}.")
+ (license license:gpl3)))
+
(define-public r-stringdb
(package
(name "r-stringdb")