summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-04-25 18:34:19 +0100
committerChristopher Baines <mail@cbaines.net>2022-04-25 18:34:19 +0100
commitfa1b772fb35caee4dff6d05e8e8db741c1568e0d (patch)
tree2f77ba8c510a10b110f4bce06b495bfa39791955
parenta14c6352662bfa6715ec70b3d280a6d1d599ad0c (diff)
downloadguix-patches-base-for-series-12183.tar
guix-patches-base-for-series-12183.tar.gz
gnu: nginx-lua-module: Fix builder.base-for-series-12188base-for-series-12183
Probably broken by the changes to the nginx package in 4079cd9ba33b0d2cd23897899dfc66836797e4d2. * gnu/packages/web.scm (nginx-lua-module)[arguments]: Make the modify-phases part a gexp, and move #:configure-flags to the end of the list.
-rw-r--r--gnu/packages/web.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0b629c0269..bc913664e3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -726,42 +726,42 @@ documentation.")
,@(package-inputs nginx)))
(arguments
(substitute-keyword-arguments
- `(#:configure-flags '("--add-dynamic-module=.")
- #:make-flags '("modules")
+ `(#:make-flags '("modules")
#:modules ((guix build utils)
(guix build gnu-build-system)
(ice-9 popen)
(ice-9 regex)
(ice-9 textual-ports))
- ,@(package-arguments nginx))
+ ,@(package-arguments nginx)
+ #:configure-flags '("--add-dynamic-module=."))
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'unpack-nginx-sources
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (begin
- ;; The nginx source code is part of the module’s source.
- (format #t "decompressing nginx source code~%")
- (let ((tar (assoc-ref inputs "tar"))
- (nginx-srcs (assoc-ref inputs "nginx-sources")))
- (invoke (string-append tar "/bin/tar")
- "xvf" nginx-srcs "--strip-components=1"))
- #t)))
- (add-before 'configure 'set-luajit-env
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((luajit (assoc-ref inputs "luajit")))
- (setenv "LUAJIT_LIB"
- (string-append luajit "/lib"))
- (setenv "LUAJIT_INC"
- (string-append luajit "/include/luajit-2.1"))
- #t)))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((modules-dir (string-append (assoc-ref outputs "out")
- "/etc/nginx/modules")))
- (install-file "objs/ngx_http_lua_module.so" modules-dir)
- #t)))
- (delete 'fix-root-dirs)
- (delete 'install-man-page)))))
+ #~(modify-phases #$phases
+ (add-after 'unpack 'unpack-nginx-sources
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (begin
+ ;; The nginx source code is part of the module’s source.
+ (format #t "decompressing nginx source code~%")
+ (let ((tar (assoc-ref inputs "tar"))
+ (nginx-srcs (assoc-ref inputs "nginx-sources")))
+ (invoke (string-append tar "/bin/tar")
+ "xvf" nginx-srcs "--strip-components=1"))
+ #t)))
+ (add-before 'configure 'set-luajit-env
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((luajit (assoc-ref inputs "luajit")))
+ (setenv "LUAJIT_LIB"
+ (string-append luajit "/lib"))
+ (setenv "LUAJIT_INC"
+ (string-append luajit "/include/luajit-2.1"))
+ #t)))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((modules-dir (string-append (assoc-ref outputs "out")
+ "/etc/nginx/modules")))
+ (install-file "objs/ngx_http_lua_module.so" modules-dir)
+ #t)))
+ (delete 'fix-root-dirs)
+ (delete 'install-man-page)))))
(synopsis "NGINX module for Lua programming language support")
(description "This NGINX module provides a scripting support with Lua
programming language.")))