summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2022-02-08 19:05:41 +0100
committerBrice Waegeneire <brice@waegenei.re>2022-02-12 14:08:23 +0100
commite641d707e1ec8de2bfc658dcd1757360300aa509 (patch)
treeb049552bf67cf27a438259d2949a86b8eb9d0274
parent9c8f68f4796f23c11173fa3f90c69bc85b224ac6 (diff)
downloadguix-patches-base-for-series-11387.tar
guix-patches-base-for-series-11387.tar.gz
* gnu/packages/vpn.scm (protonvpn-cli)[arguments]: Remove sanity-check phase.
-rw-r--r--gnu/packages/vpn.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 9fd0e4493d..a82db31e30 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -769,7 +769,11 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
"openvpn"
"procps"
"which")))))
- #t)))))
+ #t))
+ ;; The `protonvpn' script wants to write to `~user' to initialize its
+ ;; logger, so simply setting HOME=/tmp won't cut it. Remove
+ ;; sanity-check.
+ (delete 'sanity-check))))
(native-inputs
(list python-docopt))
(inputs