summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-02-05 14:05:14 -0500
committerLeo Famulari <leo@famulari.name>2022-02-09 01:39:47 -0500
commitbc54947410689cc752ca962b0b4d27fa799265bf (patch)
treefee5e52f14767ca4e1e6ce18fb6f5cf6e31e6dcc
parentc76d9a68aee8bb5ccea47c2e28abedb649299c2c (diff)
downloadguix-patches-base-for-series-11354.tar
guix-patches-base-for-series-11354.tar.gz
This kernel series has reached the end of its life: https://lore.kernel.org/all/164387713713082@kroah.com/T/#t https://lwn.net/Articles/883685/ Discussion within Guix: https://lists.gnu.org/archive/html/guix-devel/2022-01/msg00020.html https://lists.gnu.org/archive/html/guix-devel/2022-02/msg00007.html * gnu/packages/linux.scm (linux-libre-4.4-version, linux-libre-4.4-gnu-revision, deblob-scripts-4.4, linux-libre-4.4-pristine-source, linux-libre-4.4-source, linux-libre-headers-4.4, linux-libre-4.4): Remove variables.
-rw-r--r--gnu/packages/linux.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c745d8217b..08ef82efaf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -465,21 +465,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.9)))
-(define-public linux-libre-4.4-version "4.4.302")
-(define-public linux-libre-4.4-gnu-revision "gnu1")
-(define deblob-scripts-4.4
- (linux-libre-deblob-scripts
- linux-libre-4.4-version
- linux-libre-4.4-gnu-revision
- (base32 "1mmnv77432la5dkhpy1n8w59c0v6l08fyf2ggh294gyrx8nbci11")
- (base32 "0wdaj40pcq9wg5xnz2zj3jj8bawhfgqxcwp6dnavbf9lq0gca48p")))
-(define-public linux-libre-4.4-pristine-source
- (let ((version linux-libre-4.4-version)
- (hash (base32 "1cvnydc7y5xrb1c4yfmsl846dd1jfrr7xf62gxbhnkk01fs7n09m")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-4.4)))
-
(define %boot-logo-patch
;; Linux-Libre boot logo featuring Freedo and a gnu.
(origin
@@ -545,10 +530,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(source-with-patches linux-libre-4.9-pristine-source
(list %boot-logo-patch)))
-(define-public linux-libre-4.4-source
- (source-with-patches linux-libre-4.4-pristine-source
- (list %boot-logo-patch)))
-
;;;
;;; Kernel headers.
@@ -660,11 +641,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-4.9-gnu-revision
linux-libre-4.9-source))
-(define-public linux-libre-headers-4.4
- (make-linux-libre-headers* linux-libre-4.4-version
- linux-libre-4.4-gnu-revision
- linux-libre-4.4-source))
-
;; The following package is used in the early bootstrap, and thus must be kept
;; stable and with minimal build requirements.
(define-public linux-libre-headers-5.10.35
@@ -1000,19 +976,6 @@ It has been modified to remove all non-free binary blobs.")
'("x86_64-linux" "i686-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-4.4
- (make-linux-libre* linux-libre-4.4-version
- linux-libre-4.4-gnu-revision
- linux-libre-4.4-source
- '("x86_64-linux" "i686-linux")
- #:configuration-file kernel-config
- #:extra-options
- (append
- `(;; https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00039.html
- ;; This option was removed upstream in version 4.7.
- ("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t))
- %default-extra-linux-options)))
-
;; Linux-Libre-LTS points to the *newest* released long-term support version of
;; Linux-Libre.
;; Reference: https://jxself.org/linux-libre/