summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-24 18:44:57 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-24 18:44:57 +0000
commitf336cc4fe739819115c99bc58122024241640cab (patch)
treebfd2ad0469ab5c7df7a66336531751b89811aa7e
parente5a26a1f02503f676378fe6f30dba4249c3090af (diff)
downloadguix-patches-f336cc4fe739819115c99bc58122024241640cab.tar
guix-patches-f336cc4fe739819115c99bc58122024241640cab.tar.gz
gnu: bowtie: Replace invalid characters.
* gnu/packages/bioinformatics.scm (bowtie)[arguments]: Replace invalid quotes with straight quotes in the 'configure phase.
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4743e56abc..c03ffaf2ff 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1701,7 +1701,12 @@ errors at the end of reads.")
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (replace 'configure
+ (lambda _
+ ;; This "extended character" is not considered valid.
+ (substitute* "processor_support.h"
+ (("“") "\"")
+ (("”") "\""))))
(replace 'check
(lambda _
(invoke "perl"