summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:20:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commit0d50d0df0866430814d3b55cb305c352e796cd55 (patch)
treea45211fcb29a7f721c995274457525b6968dbd3d
parent2d704608924baf2a206c997e462ae07c516e4391 (diff)
downloadguix-patches-0d50d0df0866430814d3b55cb305c352e796cd55.tar
guix-patches-0d50d0df0866430814d3b55cb305c352e796cd55.tar.gz
gnu: Add r-msigdbr.
* gnu/packages/cran.scm (r-msigdbr): New variable.
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 29af7ff2b6..4e6604ac83 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13066,3 +13066,34 @@ The extrafont package makes both of these things easier.")
"This package provides the means to plot ggplot2 graphs in the style of
the XKCD web comic.")
(license license:gpl3)))
+
+(define-public r-msigdbr
+ (package
+ (name "r-msigdbr")
+ (version "6.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "msigdbr" version))
+ (sha256
+ (base32
+ "1264j1hs74kq7hyh68vfynadfi6mdpq46qm1hnwzkzzhmbzpb9cg"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/igordot/msigdbr")
+ (synopsis "MSigDB gene sets for multiple organisms")
+ (description
+ "This package provides the @dfn{Molecular Signatures Database} (MSigDB)
+gene sets typically used with the @dfn{Gene Set Enrichment Analysis} (GSEA)
+software in a standard R data frame with key-value pairs. Included are the
+original human gene symbols and Entrez IDs as well as the equivalents for
+various frequently studied model organisms such as mouse, rat, pig, fly, and
+yeast.")
+ ;; The package is covered under the Expat license, but the upstream MSigDB
+ ;; files are made available under the Creative Commons Attribution 4.0
+ ;; International license.
+ (license (list license:expat license:cc-by4.0))))