summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-01-11 01:13:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-21 01:13:58 +0100
commitb09f2aa4dae7e2a2f0f37ba831a2428fee8557d2 (patch)
treeaf8cd070150db98592a0196b9b63292b46503679
parenta94e77a8e5aafac5bf08fbfa08e2b480be345ce3 (diff)
downloadguix-patches-base-for-series-11050.tar
guix-patches-base-for-series-11050.tar.gz
* gnu/packages/crates-graphics.scm (rust-lyon-tessellation-0.17): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-graphics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 810a7b0908..dbd3607dc4 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1534,6 +1534,31 @@ graphics and video games.")
(description "This package provides SVG helpers for the lyon crates.")
(license (list license:expat license:asl2.0))))
+(define-public rust-lyon-tessellation-0.17
+ (package
+ (name "rust-lyon-tessellation")
+ (version "0.17.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lyon-tessellation" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0q2pccjszda26asylnvhwsil8wvsprfjazrqdzj4i033s26y0c3j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-float-next-after" ,rust-float-next-after-0.1)
+ ("rust-lyon-path" ,rust-lyon-path-0.17)
+ ("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-lyon-extra" ,rust-lyon-extra-0.17))))
+ (home-page "https://github.com/nical/lyon")
+ (synopsis "Low level path tessellation library")
+ (description
+ "This package provides a low level path tessellation library.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-osmesa-sys-0.1
(package
(name "rust-osmesa-sys")