summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-13 22:08:52 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:20:42 +0100
commit0846eaecd45783bf40e8dc67b0c16f71068524b7 (patch)
treea51ec815ec3d75c103158f79cf0f8e613e325ea9
parent508472d3546a679b8bac62357c771ae91a4be30f (diff)
downloadguix-patches-base-for-issue-50054.tar
guix-patches-base-for-issue-50054.tar.gz
"xdot" would always fail to run when graphviz "dot" binary is not available directly in the user system. This patch fixes it by adding graphviz binaries from the inputs to the PATH environment variable in "xdot" wrapping script. Reported by Ada Stevenson <adanskana@gmail.com> in https://debbugs.gnu.org/cgi/bugreport.cgi?bug=70910 * gnu/packages/graphviz.scm (xdot) [arguments]: Add the "bin" directory from the graphviz input to the xdot wrapping. Change-Id: Iba4bbc37daf07407ad4c18b822956fbb730c0033 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/graphviz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 0fc5c6024e..18f4fc147d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -314,9 +314,12 @@ Graphviz and LaTeX.")
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (graphviz (assoc-ref inputs "graphviz"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/xdot")
+ `("PATH" ":" prefix
+ (,(string-append graphviz "/bin")))
`("GI_TYPELIB_PATH" ":" prefix
(,gi-typelib-path))
`("GUIX_PYTHONPATH" ":" prefix