summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d05737b6c3..2a583c64c1 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -246,26 +246,25 @@ tmpfs/ramfs filesystems.")
"18h51i3x5cbqhlj5rm23m9sfw63gaaby5czln5w6qpqj3ifdsf29"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-locales-and-python
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "tests/t0251-gpt-unicode.sh"
- (("C.UTF-8") "en_US.utf8")) ;not in Glibc locales
- (substitute* "tests/msdos-overlap"
- (("/usr/bin/python") (which "python")))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-locales-and-python
+ (lambda _
+ (substitute* "tests/t0251-gpt-unicode.sh"
+ (("C.UTF-8") "en_US.utf8")) ;not in Glibc locales
+ (substitute* "tests/msdos-overlap"
+ (("/usr/bin/python") (which "python"))))))))
(inputs
(list lvm2 readline
`(,util-linux "lib")))
(native-inputs
- `(("gettext" ,gettext-minimal)
+ (list gettext-minimal
- ;; For the tests.
- ("e2fsprogs" ,e2fsprogs)
- ("perl" ,perl)
- ("python-wrapper" ,python-wrapper)
- ("util-linux" ,util-linux)))
+ ;; For the tests.
+ e2fsprogs
+ perl
+ python-wrapper
+ util-linux))
(home-page "https://www.gnu.org/software/parted/")
(synopsis "Disk partition editor")
(description