summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-05-07 07:58:27 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-05-07 08:16:17 +0200
commitfe794295ab7aff517b323b04845b5a1e66284c25 (patch)
treeb3e93a2f5dd56576980ba69e7ca0ca1eca243da4
parentee70ed5bf50e781a6a43985211aa763e28db62b9 (diff)
downloadguix-patches-fe794295ab7aff517b323b04845b5a1e66284c25.tar
guix-patches-fe794295ab7aff517b323b04845b5a1e66284c25.tar.gz
gnu: ocaml-reactivedata: Update to 0.3.
* gnu/packages/ocaml.scm (ocaml-reactivedata): Update to 0.3.
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 4 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9d03f545e8..d2308f976b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7807,10 +7807,9 @@ generate OCaml code from .glade files), libpanel, librsvg and quartz.")
(license license:lgpl2.0)))
(define-public ocaml-reactivedata
- ;; Future releases will use dune.
(package
(name "ocaml-reactivedata")
- (version "0.2.2")
+ (version "0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7819,26 +7818,11 @@ generate OCaml code from .glade files), libpanel, librsvg and quartz.")
(file-name (git-file-name name version))
(sha256
(base32
- "0l5z0fsckqkywjbn2nwy3s55h85yx8scc4hq9qzr9ig3hrq1mfb0"))))
+ "0gmpfnw08c7hx4bsgrgvp6w7pq2ghqxq3qd1cbdyscbg9n22jrca"))))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'fix-deprecated
- (lambda _
- (substitute*
- "src/reactiveData.ml"
- (("Pervasives.compare") "compare"))
- #t))
- (add-before 'install 'forget-makefile
- ;; Ensure we use opam to install files
- (lambda _
- (delete-file "Makefile")
- #t)))))
- (build-system ocaml-build-system)
+ `(#:tests? #f)) ;no tests
+ (build-system dune-build-system)
(properties `((upstream-name . "reactiveData")))
- (native-inputs
- (list ocamlbuild opam))
(propagated-inputs
(list ocaml-react))
(home-page "https://github.com/ocsigen/reactiveData")