summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-05 19:20:25 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-05 19:20:25 +0000
commitf4d3e7b82bf20e1c845f6b952478fffa5dbd701b (patch)
tree665c99f8a3fbcf79ad9c2a2de2b1bd2b6c376618
parent5f1e33f76c1c6eb3d9c90eac9bd94cdacf8bfd2a (diff)
downloadguix-patches-f4d3e7b82bf20e1c845f6b952478fffa5dbd701b.tar
guix-patches-f4d3e7b82bf20e1c845f6b952478fffa5dbd701b.tar.gz
gnu: gdb: Fix cross-compilation for Hurd.
* gnu/packages/patches/gdb-hurd.patch: Update it. * gnu/packages/gdb.scm (gdb)[source]: Add it.
-rw-r--r--gnu/packages/gdb.scm4
-rw-r--r--gnu/packages/patches/gdb-hurd.patch77
2 files changed, 22 insertions, 59 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 543beee8da..e51e17d5da 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -52,7 +52,9 @@
version ".tar.xz"))
(sha256
(base32
- "0aag1c0fw875pvhjg1qp7x8pf6gf92bjv5gcic5716scacyj58da"))))
+ "0aag1c0fw875pvhjg1qp7x8pf6gf92bjv5gcic5716scacyj58da"))
+ (patches
+ (search-patches "gdb-hurd.patch"))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/packages/patches/gdb-hurd.patch b/gnu/packages/patches/gdb-hurd.patch
index 0af8d4dc28..c4763cecbd 100644
--- a/gnu/packages/patches/gdb-hurd.patch
+++ b/gnu/packages/patches/gdb-hurd.patch
@@ -1,69 +1,30 @@
-Taken from upstream, removed ChangeLog.
+Taken from upstream.
-From 6930bffe3373690b3431d6291f9f7c116d6a1ec4 Mon Sep 17 00:00:00 2001
+From dca11eb872c96f86388890b3750e450cc2a68700 Mon Sep 17 00:00:00 2001
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
-Date: Sat, 30 May 2020 18:35:59 +0000
-Subject: [PATCH] hurd: fix gnu_debug_flag type
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
+Date: Mon, 21 Dec 2020 16:01:07 +0000
+Subject: [PATCH] hurd: Fix getting VM_MIN/MAX_ADDRESS
-Fixes
-
-../../gdb/gnu-nat.c:96:6: error: conflicting declaration ‘bool gnu_debug_flag’
- 96 | bool gnu_debug_flag = false;
-../../gdb/gnu-nat.c: In function ‘void _initialize_gnu_nat()’:
-../../gdb/gnu-nat.c:3511:7: error: cannot
+gnu-nat.c was getting the inclusion of vm_param.h only by luck. We need
+to explicitly include it to be sure to get the definitions of
+VM_MIN/MAX_ADDRESS.
gdb/ChangeLog:
- * gnu-nat.h (gnu_debug_flag): Set type to bool.
+ * gnu-nat.c: Include <mach/vm_param.h>.
---
- gdb/ChangeLog | 4 ++++
- gdb/gnu-nat.h | 2 +-
- 2 files changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/gdb/gnu-nat.h b/gdb/gnu-nat.h
-index 77c57817b2..766f716587 100644
---- a/gdb/gnu-nat.h
-+++ b/gdb/gnu-nat.h
-@@ -111,7 +111,7 @@ extern char *proc_string (struct proc *proc);
- __proc_pid (__proc), __proc->tid, \
- host_address_to_string (__proc) , ##args); } while (0)
-
--extern int gnu_debug_flag;
-+extern bool gnu_debug_flag;
-
- #define debug(msg, args...) \
- do { if (gnu_debug_flag) \
---
-Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
-Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
-
-commit 366f550a593c7e6bae3699a4b6d65fe937af5603
-Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
-Date: Sat May 30 18:41:30 2020 +0000
-
- hurd: add missing include
-
- Fixes
-
- ../../gdb/gnu-nat.c:2522:14: error: ‘target_gdbarch’ was not declared in this scope; did you mean ‘target_detach’?
- 2522 | paddress (target_gdbarch (), memaddr), pulongest (len),
-
- gdb/Changelog:
-
- * gnu-nat.c: Include "gdbarch.h".
+ gdb/gnu-nat.c | 1 +
+ 1 file changed, 1 insertion(+)
diff --git a/gdb/gnu-nat.c b/gdb/gnu-nat.c
-index 3b438a9a43..9b93488b41 100644
+index 1693ce0c43d..6f290be0d51 100644
--- a/gdb/gnu-nat.c
+++ b/gdb/gnu-nat.c
-@@ -64,6 +64,7 @@ extern "C"
- #include "language.h"
- #include "target.h"
- #include "gdbsupport/gdb_wait.h"
-+#include "gdbarch.h"
- #include "gdbcmd.h"
- #include "gdbcore.h"
- #include "gdbthread.h"
+@@ -32,6 +32,7 @@ extern "C"
+ #include <mach/message.h>
+ #include <mach/notify.h>
+ #include <mach/vm_attributes.h>
++#include <mach/vm_param.h>
+
+ #include <hurd.h>
+ #include <hurd/interrupt.h>