summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:13:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:20:41 +0100
commitf1c8df4ee950efc4ad05ea2d4add7562ba971002 (patch)
treec2bcc8ff1622fa6f5e38b07035fe6d0bbf32bd11
parent1f8e29256ed5137477658c10ff9dca324202e96c (diff)
downloadguix-patches-f1c8df4ee950efc4ad05ea2d4add7562ba971002.tar
guix-patches-f1c8df4ee950efc4ad05ea2d4add7562ba971002.tar.gz
gnu: Add go-github-com-elgris-jsondiff.
* gnu/packages/golang-check.scm (go-github-com-elgris-jsondiff): New variable. Change-Id: Ie0b85240bd0a9e68f9274edab6a15f34f42de26c
-rw-r--r--gnu/packages/golang-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 12a7a24c21..9e537d7d17 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -192,6 +192,35 @@ style).
@end itemize")
(license license:isc)))
+(define-public go-github-com-elgris-jsondiff
+ (package
+ (name "go-github-com-elgris-jsondiff")
+ (version "0.0.0-20160530203242-765b5c24c302")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elgris/jsondiff")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jm1q0s531hmkqdx8jqphfpmzysn44aphkpwlzqwp3hkz89g4d4q"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/elgris/jsondiff"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-mgutz-ansi))
+ (home-page "https://github.com/elgris/jsondiff")
+ (synopsis "JSON diff diagnostics for Golang")
+ (description
+ "This package provides a simple little tool that produces readable diff
+of 2 JSON-able and convertible to @code{map[string]interface{}} objects.
+Useful for diagnostics or debugging")
+ (license license:expat)))
+
(define-public go-github-com-felixge-fgprof
(package
(name "go-github-com-felixge-fgprof")