summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched parenthesis <paren@disroot.org>2021-12-25 19:54:22 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-12-27 14:15:15 +0200
commitef804b0c720509c999db8debf2d5fa2fc0fa3ec8 (patch)
treecc725b9071937a5d3682ef4823e131be295dc670
parentaee90c84b2ced501416b591dae349f39e46b5f49 (diff)
downloadguix-patches-ef804b0c720509c999db8debf2d5fa2fc0fa3ec8.tar
guix-patches-ef804b0c720509c999db8debf2d5fa2fc0fa3ec8.tar.gz
gnu: Add rust-1.55.
* gnu/packages/rust.scm (rust-1.55): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/rust.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 2a43e88727..887205d162 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -771,6 +772,10 @@ safety and thread safety guarantees.")
`("procps" ,procps)
(package-native-inputs base-rust))))))
+(define-public rust-1.55
+ (rust-bootstrapped-package
+ rust-1.54 "1.55.0" "07l28f7grdmi65naq71pbmvdd61hwcpi40ry7kp7dy7m233rldxj"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time