summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 14:56:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:43 +0100
commite86eb91206b4588ffc77b001b0d2b88c2411f583 (patch)
tree2a651bf8d28ab79e0b878c2c025c46d80ab6e0a8
parentfcb3a177f6d182c53728431b31d29799dde56a09 (diff)
downloadguix-patches-e86eb91206b4588ffc77b001b0d2b88c2411f583.tar
guix-patches-e86eb91206b4588ffc77b001b0d2b88c2411f583.tar.gz
gnu: Add go-github-com-stretchr-testify-next.
* gnu/packages/golang-check.scm (go-github-com-stretchr-testify-next): New variable. Change-Id: Ib24b9f68be04ba4066fb130909e59e1df71e4bf7
-rw-r--r--gnu/packages/golang-check.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 4984d552d3..2b70e8565f 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -748,6 +748,21 @@ Features include:
(propagated-inputs
(list go-gopkg-in-yaml-v3)))))
+(define-public go-github-com-stretchr-testify-next
+ (package
+ (inherit go-github-com-stretchr-testify)
+ (name "go-github-com-stretchr-testify")
+ (version "1.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/testify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))))
+
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")