summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:40 +0200
commite6c3e7d7416daebebe4d3e2d086461d6fb89ce93 (patch)
tree50b0cdb23f5ea0ff154b6cbdef89a9e6cc18161b
parentde15ca7af8cfb92f716ad8600f9295a2dca581a2 (diff)
downloadguix-patches-e6c3e7d7416daebebe4d3e2d086461d6fb89ce93.tar
guix-patches-e6c3e7d7416daebebe4d3e2d086461d6fb89ce93.tar.gz
gnu: beep: Use G-expressions.
* gnu/packages/terminals.scm (beep)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/terminals.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 59949daf21..2367eccb3b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -58,6 +58,7 @@
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -575,27 +576,27 @@ to all types of devices that provide serial consoles.")
(base32 "0dgrb5yg4ys1fa4hs95iz3m2yhryfzzw0j6g6yf6vhbys4ihcf40"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "prefix=" (assoc-ref %outputs "out"))
- (string-append "pkgdocdir=$(docdir)/" ,name "-" ,version))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-before 'check 'patch-tests
- (lambda _
- (substitute* "GNUmakefile"
- (("/bin/bash")
- (which "bash"))
- ;; XXX In the build environment, $(PWD) is the *parent* directory
- ;; /tmp/guix-build-beep-x.y.drv-0! A pure guix shell works fine.
- (("\\$\\(PWD\\)" pwd)
- (string-append pwd "/source")))
- (substitute* (find-files "tests" "\\.expected")
- ;; The build environment lacks /dev/{console,tty*}.
- ;; In fact, even nckx's regular Guix System lacks ttyS1…
- ((": Permission denied")
- ": No such file or directory")))))))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output)
+ (string-append "pkgdocdir=$(docdir)/" #$name "-" #$version))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "GNUmakefile"
+ (("/bin/bash")
+ (which "bash"))
+ ;; XXX In the build environment, $(PWD) is the *parent* directory
+ ;; /tmp/guix-build-beep-x.y.drv-0! A pure guix shell works fine.
+ (("\\$\\(PWD\\)" pwd)
+ (string-append pwd "/source")))
+ (substitute* (find-files "tests" "\\.expected")
+ ;; The build environment lacks /dev/{console,tty*}.
+ ;; In fact, even nckx's regular Guix System lacks ttyS1…
+ ((": Permission denied")
+ ": No such file or directory")))))))
(synopsis "Linux command-line utility to control the PC speaker")
(description "beep allows the user to control the PC speaker with precision,
allowing different sounds to indicate different events. While it can be run