summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:23 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:17 +0100
commite680c56d106f791e212dc3c456829683a289cbeb (patch)
treee0cfb3cca4bb9c5f74c081ba1ec281a71643c75c
parentd85b3b59a692a21b60f94691a5af985aaf71ec74 (diff)
downloadguix-patches-e680c56d106f791e212dc3c456829683a289cbeb.tar
guix-patches-e680c56d106f791e212dc3c456829683a289cbeb.tar.gz
gnu: Add node-serialport-parser-regex.
* gnu/packages/node-xyz.scm (node-serialport-parser-regex): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/node-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b66aab7c0c..7ce9476555 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1130,3 +1130,25 @@ This package provides the @code{Binding} class, which uses a native addon to
talk to the underlying system. You never have to use @code{Binding} objects
directly. There is also a @code{MockBinding} available (but not yet packaged
for Guix) to assist with testing.")))
+
+(define-public node-serialport-parser-regex
+ (package
+ (inherit node-serialport-binding-abstract)
+ (name "node-serialport-parser-regex")
+ (version "9.2.4")
+ (inputs `())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-regex"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser to split data on a regular expression")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{Regex}, a parser that uses a regular
+expression to split the incoming text.")))