summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2023-02-23 09:54:11 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-05 23:06:55 +0100
commitde45676c2a4c4c04b2a172c05af78a5f1ded5636 (patch)
tree0582e412f59e8f3de28f8278fdac363fd49dc182
parent506f8ffff1d8b99de95e76e4f9b25c069ca3330f (diff)
downloadguix-patches-de45676c2a4c4c04b2a172c05af78a5f1ded5636.tar
guix-patches-de45676c2a4c4c04b2a172c05af78a5f1ded5636.tar.gz
gnu: Update ocaml-eio to 0.8.1.
* gnu/packages/ocaml.scm (ocaml-eio): Update to 0.8.1. [native-inputs]: Add ocaml-mdx. (ocaml-mtime): Update to 2.0.0. [source]: Use https instead of http. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 553638597e..f494d1112b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2366,14 +2366,14 @@ manipulate such data.")
(define-public ocaml-mtime
(package
(name "ocaml-mtime")
- (version "1.4.0")
+ (version "2.0.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://erratique.ch/software/mtime/releases/"
+ (uri (string-append "https://erratique.ch/software/mtime/releases/"
"mtime-" version ".tbz"))
(sha256
(base32
- "1xy6lg52n2zynp4p164ym9j0f1b95j5n4bi5y4mbdrry9w99h32m"))))
+ "1ss4w3qxsfp51d88r0j7dzqs05dbb1xdx11hn1jl9cvd03ma0g9z"))))
(build-system ocaml-build-system)
(native-inputs
(list ocamlbuild opam))
@@ -2841,7 +2841,7 @@ to which allows adding and looking up bindings in a type safe manner.")
(define ocaml-eio
(package
(name "ocaml-eio")
- (version "0.7")
+ (version "0.8.1")
(home-page "https://github.com/ocaml-multicore/eio")
(source
(origin
@@ -2851,7 +2851,7 @@ to which allows adding and looking up bindings in a type safe manner.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256 (base32
- "118raxdwv6pn5b152ffdhmwdi0l4wlwflcj2nmckfmm7v1z2fq4s"))))
+ "02q9i5wbb2497vd4ypc9d9p4zi3lmx0rsv8faiy7h8dnnzbjjf4z"))))
(build-system dune-build-system)
(arguments `(#:package "eio"))
(propagated-inputs (list ocaml-bigstringaf
@@ -2865,7 +2865,10 @@ to which allows adding and looking up bindings in a type safe manner.")
ocaml-hmap
ocaml-mtime
ocaml-odoc))
- (native-inputs (list ocaml-astring ocaml-crowbar ocaml-alcotest))
+ (native-inputs (list ocaml-astring
+ ocaml-crowbar
+ ocaml-alcotest
+ ocaml-mdx))
(synopsis "Effect-based direct-style IO API for OCaml")
(description "This package provides an effect-based IO API for multicore
OCaml with fibers.")