summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-12-28 20:55:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 16:09:02 +0000
commitdb88f712f82e5cc24b9cc05324bccab6c5fc16e3 (patch)
tree07f34bef818e10ac74b7223bdbc35f064bb935e6
parent892b4a9a0255d53940079ed840ea4362ee0ae130 (diff)
downloadguix-patches-db88f712f82e5cc24b9cc05324bccab6c5fc16e3.tar
guix-patches-db88f712f82e5cc24b9cc05324bccab6c5fc16e3.tar.gz
gnu: Add python-pgmpy.
* gnu/packages/statistics.scm (python-pgmpy): New variable. Change-Id: Ic9a42b534500cd1ed98869b8ac4bd3700ee3e2f6 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/statistics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 8cfc9507ca..04f68c9c36 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
@@ -7775,3 +7776,40 @@ weighting schemes.")
statistical summary in arrays and enumerables.")
(home-page "https://github.com/mrkn/enumerable-statistics")
(license license:expat)))
+
+(define-public python-pgmpy
+ (package
+ (name "python-pgmpy")
+ (version "0.1.24")
+ (source
+ (origin
+ (method git-fetch) ;pypi package does not include test data
+ (uri (git-reference
+ (url "https://github.com/pgmpy/pgmpy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fvzh6v0yhgdryczamvzhfy2ymywkh0ssx4rl47xnfvi43hnij90"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-daft
+ python-joblib
+ python-networkx
+ python-numpy
+ python-opt-einsum
+ python-pandas
+ python-pyparsing
+ python-pytorch
+ python-scikit-learn
+ python-scipy
+ python-statsmodels
+ python-tqdm))
+ (native-inputs (list python-mock
+ python-pytest))
+ (home-page "https://github.com/pgmpy/pgmpy")
+ (synopsis "Probabilistic Graphical Models library")
+ (description "This package provides a library for Probabilistic
+Graphical Models. It can be used for learning (Structure and Parameter),
+inference (Probabilistic and Causal), and simulations in Bayesian
+Networks.")
+ (license license:expat)))