summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-08-19 17:22:30 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-08-19 17:40:03 -0700
commitd2b85f8906489fb95d8be41d6ba9fd520a5967d0 (patch)
tree73b23758cb33d410f467ec12a892a12d5a62cd89
parent397b103bef313c84eb662051fbcd28e223806bd3 (diff)
downloadguix-patches-d2b85f8906489fb95d8be41d6ba9fd520a5967d0.tar
guix-patches-d2b85f8906489fb95d8be41d6ba9fd520a5967d0.tar.gz
gnu: libnet: Set man page date to built reproducibly.
* gnu/packages/networking.scm (libnet)[argument]: Add 'fix-manpage-date phase.
-rw-r--r--gnu/packages/networking.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f088b88c73..2fea1b2b59 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3055,6 +3055,11 @@ interface and a programmable text output for scripting.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-manpage-date
+ (lambda _
+ ;; Replace current date with specific date to build reproducibly
+ (substitute* "doc/fixmanpages.in"
+ (("pod2man -d .* -n") "pod2man -d \"1970-01-01\" -n"))))
(add-before 'build 'build-doc
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "-C" "doc" "doc"