summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-04-25 15:55:39 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-04-25 15:55:39 +0200
commitd0f6b8d7b07665f22231338c2cc9ebf1b6ff7de2 (patch)
tree7096eb557958f95395d66335ee8432f3154b80a0
parent5183ff2b9125ffa47c761f15cbda6a91080b6812 (diff)
downloadguix-patches-d0f6b8d7b07665f22231338c2cc9ebf1b6ff7de2.tar
guix-patches-d0f6b8d7b07665f22231338c2cc9ebf1b6ff7de2.tar.gz
gnu: Add emacs-bitbake-modes.
* gnu/packages/emacs-xyz.scm (emacs-bitbake-modes): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf0e0da7b3..80e2d3c1ab 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
-;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
@@ -30884,3 +30884,26 @@ headlines, keywords, tables and source blocks.")
zoomable and moveable map display, display of tracks and POIs from GPX files,
parallel fetching of tiles with cURL, and more.")
(license license:gpl3+)))
+
+(define-public emacs-bitbake-modes
+ (package
+ (name "emacs-bitbake-modes")
+ (version "0.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/olanilsson/bitbake-modes")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1580cfpfmsjwiq6v2vsqjwhzj9m4lrhhf3nffmbzp36r6q5n8611"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-mmm-mode))
+ (home-page "https://bitbucket.org/olanilsson/bitbake-modes")
+ (synopsis "Emacs major modes for bitbake")
+ (description
+"@code{emacs-bitbake-modes} is a collection of major modes and tools that can
+be useful when working with the bitbake files in Yocto and OpenEmbedded
+projects.")
+ (license license:gpl3+)))