summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 09:12:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commitcfc5f07ee96d09224ee6676abda32b3c6dade50d (patch)
treefac304f44620d19123b89d7e053ec628708de29b
parentc73f70d3d50db50c6dcd6a5fd55b448bc7e36fd7 (diff)
downloadguix-patches-cfc5f07ee96d09224ee6676abda32b3c6dade50d.tar
guix-patches-cfc5f07ee96d09224ee6676abda32b3c6dade50d.tar.gz
gnu: go-github-com-mattn-go-colorable: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-colorable): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/textutils.scm: Add (gnu packages golang-xyz) module. Change-Id: I7a9763ebd498e071b17abbde838a7cbf8fc891de
-rw-r--r--gnu/packages/golang-xyz.scm26
-rw-r--r--gnu/packages/golang.scm25
-rw-r--r--gnu/packages/textutils.scm1
3 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5aa2bfa169..ec135f2b73 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1787,6 +1787,32 @@ implementing features like:
(description "This package provides an idiomatic Go retry module.")
(license license:expat)))
+(define-public go-github-com-mattn-go-colorable
+ (package
+ (name "go-github-com-mattn-go-colorable")
+ (version "0.1.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-colorable")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05hl2ddp67p5kj3ix4zzqqjh4fan4ban3vgw8f98simwigs3q41j"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mattn/go-colorable"))
+ (propagated-inputs
+ (list go-github-com-mattn-go-isatty))
+ (home-page "https://github.com/mattn/go-colorable")
+ (synopsis "Handle ANSI color escapes on Windows")
+ (description
+ "This package provides @code{colorable}, a module that makes it possible
+to handle ANSI color escapes on Windows.")
+ (license license:expat)))
+
(define-public go-github-com-mattn-go-isatty
(package
(name "go-github-com-mattn-go-isatty")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ed79a8b692..58eedc526b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4351,31 +4351,6 @@ The yaml package supports most of YAML 1.2, but preserves some behavior from
(description "This package provides a Golang Matrix client.")
(license license:asl2.0)))
-(define-public go-github-com-mattn-go-colorable
- (package
- (name "go-github-com-mattn-go-colorable")
- (version "0.1.13")
- (home-page "https://github.com/mattn/go-colorable")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "05hl2ddp67p5kj3ix4zzqqjh4fan4ban3vgw8f98simwigs3q41j"))))
- (build-system go-build-system)
- (propagated-inputs
- (list go-github-com-mattn-go-isatty))
- (arguments
- '(#:import-path "github.com/mattn/go-colorable"))
- (synopsis "Handle ANSI color escapes on Windows")
- (description "This package provides @code{colorable}, a module that
-makes it possible to handle ANSI color escapes on Windows.")
- (license license:expat)))
-
(define-public go-github-com-mattn-go-pointer
(let ((commit "a0a44394634f41e4992b173b24f14fecd3318a67")
(revision "1"))
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 484ba6939b..ff42f748ea 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -70,6 +70,7 @@
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
#:use-module (gnu packages golang-crypto)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages java)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)