summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-11-25 01:21:11 +0000
committerAndrew Tropin <andrew@trop.in>2023-02-09 17:36:23 +0400
commitce7d0d689c07a7a6fd11d5d00f0e6c990cb4ee07 (patch)
treef4eab339288e3f899678aab1cada42ebacb3ac37
parent1a5f5694a7cd4bb19e9de27266e06b80d33d95cd (diff)
downloadguix-patches-ce7d0d689c07a7a6fd11d5d00f0e6c990cb4ee07.tar
guix-patches-ce7d0d689c07a7a6fd11d5d00f0e6c990cb4ee07.tar.gz
gnu: tree-sitter: Move to its own module.
* gnu/packages/text-editors.scm (tree-sitter): Move to ... * gnu/packages/tree-sitter.scm: ... here, a new module. * gnu/packages/vim.scm: Use (gnu packages tree-sitter). * gnu/packages/emacs.scm: Use (gnu packages tree-sitter). * gnu/local.mk (GNU_SYSTEM_MODULES): Register tree-sitter.scm new module. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/engineering.scm1
-rw-r--r--gnu/packages/text-editors.scm52
-rw-r--r--gnu/packages/tree-sitter.scm78
-rw-r--r--gnu/packages/vim.scm1
6 files changed, 82 insertions, 53 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a5f4b83961..f1fed73987 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -606,6 +606,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/tmux.scm \
%D%/packages/toolkits.scm \
%D%/packages/tor.scm \
+ %D%/packages/tree-sitter.scm \
%D%/packages/tv.scm \
%D%/packages/uglifyjs.scm \
%D%/packages/uml.scm \
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 00f8a0f086..4ce41deb88 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -76,7 +76,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
- #:use-module (gnu packages text-editors) ; for tree-sitter
+ #:use-module (gnu packages tree-sitter) ; for tree-sitter
#:use-module (gnu packages web) ; for jansson
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 78059ceb7e..9db6e26a02 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -148,6 +148,7 @@
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages text-editors)
+ #:use-module (gnu packages tree-sitter)
#:use-module (gnu packages tls)
#:use-module (gnu packages tex)
#:use-module (gnu packages version-control)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f9330008e7..9c70b5c758 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -73,7 +73,6 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages hunspell)
- #:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
@@ -1256,57 +1255,6 @@ similar to vi/ex.")
FreeDOS as a functional clone of the old MS-DOS program edlin.")
(license license:gpl2+)))
-(define-public tree-sitter
- (package
- (name "tree-sitter")
- (version "0.20.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tree-sitter/tree-sitter")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
- (modules '((guix build utils)))
- (snippet '(begin
- ;; Remove bundled ICU parts
- (delete-file-recursively "lib/src/unicode")
- #t))))
- (build-system gnu-build-system)
- (inputs (list icu4c))
- (arguments
- (list #:phases
- '(modify-phases %standard-phases
- (delete 'configure))
- #:tests? #f ; there are no tests for the runtime library
- #:make-flags
- #~(list (string-append "PREFIX="
- #$output)
- (string-append "CC="
- #$(cc-for-target)))))
- (home-page "https://tree-sitter.github.io/tree-sitter/")
- (synopsis "Incremental parsing system for programming tools")
- (description
- "Tree-sitter is a parser generator tool and an incremental parsing
-library. It can build a concrete syntax tree for a source file and efficiently
-update the syntax tree as the source file is edited.
-
-Tree-sitter aims to be:
-
-@itemize
-@item General enough to parse any programming language
-@item Fast enough to parse on every keystroke in a text editor
-@item Robust enough to provide useful results even in the presence of syntax errors
-@item Dependency-free so that the runtime library (which is written in pure C)
-can be embedded in any application
-@end itemize
-
-This package includes the @code{libtree-sitter} runtime library.
-")
- (license license:expat)))
-
(define-public mle
(package
(name "mle")
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
new file mode 100644
index 0000000000..a841ded429
--- /dev/null
+++ b/gnu/packages/tree-sitter.scm
@@ -0,0 +1,78 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
+;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages tree-sitter)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages icu4c)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public tree-sitter
+ (package
+ (name "tree-sitter")
+ (version "0.20.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tree-sitter/tree-sitter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ ;; Remove bundled ICU parts
+ (delete-file-recursively "lib/src/unicode")
+ #t))))
+ (build-system gnu-build-system)
+ (inputs (list icu4c))
+ (arguments
+ (list #:phases
+ '(modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f ; there are no tests for the runtime library
+ #:make-flags
+ #~(list (string-append "PREFIX="
+ #$output)
+ (string-append "CC="
+ #$(cc-for-target)))))
+ (home-page "https://tree-sitter.github.io/tree-sitter/")
+ (synopsis "Incremental parsing system for programming tools")
+ (description
+ "Tree-sitter is a parser generator tool and an incremental parsing
+library. It can build a concrete syntax tree for a source file and efficiently
+update the syntax tree as the source file is edited.
+
+Tree-sitter aims to be:
+
+@itemize
+@item General enough to parse any programming language
+@item Fast enough to parse on every keystroke in a text editor
+@item Robust enough to provide useful results even in the presence of syntax errors
+@item Dependency-free so that the runtime library (which is written in pure C)
+can be embedded in any application
+@end itemize
+
+This package includes the @code{libtree-sitter} runtime library.
+")
+ (license license:expat)))
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 0593986d87..eda25dc909 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages tcl)
#:use-module (gnu packages text-editors)
#:use-module (gnu packages terminals)
+ #:use-module (gnu packages tree-sitter)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))