summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-11 19:29:13 +0100
committerMarius Bakke <marius@gnu.org>2022-02-11 23:54:31 +0100
commitc71dca05cfc2915e658f6b4db49dc794a1836bb0 (patch)
treed40486c9efe5e26917e6085c05d496cb84566d60
parentf2ff26f34d8249503bb3f843853b41ba1d1c16b5 (diff)
downloadguix-patches-c71dca05cfc2915e658f6b4db49dc794a1836bb0.tar
guix-patches-c71dca05cfc2915e658f6b4db49dc794a1836bb0.tar.gz
gnu: ungoogled-chromium: Update to 98.0.4758.80-1.
* gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%chromium-version): Set to 98.0.4758.80. (arch-patch, %arch-patches): Remove variables. (%guix-patches): Remove accelerated video decode patch which no longer works. (%ungoogled-origin): Update hash. (ungoogled-chromium-snippet): Don't apply %ARCH-PATCHES. (ungoogled-chromium)[source]: Update hash. [arguments]: Remove obsolete #:configure-flags. Adjust substitutions.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/chromium.scm58
-rw-r--r--gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch18
3 files changed, 18 insertions, 59 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a706409516..1b08b40b9c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1907,7 +1907,6 @@ dist_patch_DATA = \
%D%/packages/patches/u-boot-riscv64-fix-extlinux.patch \
%D%/packages/patches/u-boot-rk3399-enable-emmc-phy.patch \
%D%/packages/patches/ucx-tcp-iface-ioctl.patch \
- %D%/packages/patches/ungoogled-chromium-accelerated-video-decode.patch \
%D%/packages/patches/ungoogled-chromium-extension-search-path.patch \
%D%/packages/patches/ungoogled-chromium-ffmpeg-compat.patch \
%D%/packages/patches/ungoogled-chromium-RUNPATH.patch \
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index c647381d6c..795e3e7f9b 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -310,13 +310,19 @@
;; run the Blink performance tests, just remove everything to save ~70MiB.
'("third_party/blink/perf_tests"))
-(define* (arch-patch name hash #:optional (revision %arch-revision))
+(define %chromium-version "98.0.4758.80")
+(define %ungoogled-revision (string-append %chromium-version "-1"))
+(define %debian-revision "debian/90.0.4430.85-1")
+
+(define %ungoogled-origin
(origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com/archlinux"
- "/svntogit-packages/" revision "/trunk/" name))
- (file-name (string-append "ungoogled-chromium-" name))
- (sha256 (base32 hash))))
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/Eloston/ungoogled-chromium")
+ (commit %ungoogled-revision)))
+ (file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
+ (sha256
+ (base32
+ "0a8y9yz6xyh025gk3dr0ndrdwmrslhd1ph2f8nivmqk61j7c2g8h"))))
(define* (debian-patch name hash #:optional (revision %debian-revision))
(origin
@@ -328,15 +334,6 @@
(string-append "ungoogled-chromium-" category "-" name))))
(sha256 (base32 hash))))
-(define %chromium-version "97.0.4692.99")
-(define %ungoogled-revision (string-append %chromium-version "-1"))
-(define %arch-revision "db2157b84924ce84201a8245e68a02f7d55f6491")
-(define %debian-revision "debian/90.0.4430.85-1")
-
-(define %arch-patches
- (list (arch-patch "chromium-94-ffmpeg-roll.patch"
- "1kiskdjr9v3d491sq0wdjxliflh2vq5700gbygcixayj8gkvdb2n")))
-
(define %debian-patches
(list (debian-patch "fixes/nomerge.patch"
"0lybs2b5gk08j8cr6vjrs9d3drd7qfw013z2r0y00by8dnpm74i3")
@@ -347,16 +344,6 @@
(debian-patch "system/openjpeg.patch"
"048405xh84pys0kky81vlqhaxjyxvcql4py217z01qxiv991zxaj")))
-(define %ungoogled-origin
- (origin
- (method git-fetch)
- (uri (git-reference (url "https://github.com/Eloston/ungoogled-chromium")
- (commit %ungoogled-revision)))
- (file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
- (sha256
- (base32
- "1jgxpp3wl24hq39291mgmdwcxbarxg4rpa6il53k8z3rf6gd2s4i"))))
-
(define %guix-patches
(list (local-file
(assume-valid-file-name
@@ -366,9 +353,6 @@
(search-patch "ungoogled-chromium-RUNPATH.patch")))
(local-file
(assume-valid-file-name
- (search-patch "ungoogled-chromium-accelerated-video-decode.patch")))
- (local-file
- (assume-valid-file-name
(search-patch "ungoogled-chromium-ffmpeg-compat.patch")))
(local-file
(assume-valid-file-name
@@ -400,13 +384,6 @@
patch "--no-backup-if-mismatch"))
(append '#+%debian-patches '#+%guix-patches))
- ;; These patches are "reversed"; i.e. they represent changes
- ;; already present in the source, but which should be reverted.
- (for-each (lambda (patch)
- (invoke "patch" "-Rp1" "--force" "--input"
- patch "--no-backup-if-mismatch"))
- '#$%arch-patches)
-
(with-directory-excursion #+%ungoogled-origin
(format #t "Ungooglifying...~%")
(force-output)
@@ -474,7 +451,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "1fpc07zvashaqqalwn7wxnswxclrxvhjrxy1rzr6gcq5awhaw6y9"))
+ "0wa1jhsw7qrym4x8wxmdvdvbilb8jdv0mizzib2342l61zi6cwn8"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
@@ -495,14 +472,11 @@
;; a developer build.
"is_official_build=true"
"clang_use_chrome_plugins=false"
- "is_cfi=false" ;requires ThinLTO
- "use_thin_lto=false" ;XXX lld segfaults
"use_custom_libcxx=false"
"chrome_pgo_phase=0"
"use_sysroot=false"
"goma_dir=\"\""
"enable_nacl=false"
- "enable_nacl_nonsfi=false"
"use_unofficial_version_number=false"
"treat_warnings_as_errors=false"
"use_official_google_api_keys=false"
@@ -626,6 +600,11 @@
(("#include \"third_party/jsoncpp/")
"#include \"json/"))
+ ;; This can be removed for M99.
+ (substitute* "media/gpu/chromeos/video_decoder_pipeline.cc"
+ (("third_party/libdrm/src/include/drm/drm_fourcc\\.h")
+ "libdrm/drm_fourcc.h"))
+
;; Many files try to include ICU headers from "third_party/icu/...".
;; Remove the "third_party/" prefix to use system headers instead.
(substitute* (find-files "chrome" "\\.cc$")
@@ -671,7 +650,6 @@
(substitute*
'("ui/ozone/platform/x11/gl_ozone_glx.cc"
"ui/ozone/common/egl_util.cc"
- "ui/gl/init/gl_initializer_linux_x11.cc"
"third_party/angle/src/libANGLE/renderer/gl/glx\
/FunctionsGLX.cpp")
(("libGL\\.so\\.1")
diff --git a/gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch b/gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch
deleted file mode 100644
index cbab626e59..0000000000
--- a/gnu/packages/patches/ungoogled-chromium-accelerated-video-decode.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Upstream Chromium no longer supports hardware accelerated video decoding
-on GNU/Linux, yet it still works fine on many systems. This patch "unexpires"
-the support.
-
-Taken from Arch Linux:
-https://github.com/archlinux/svntogit-packages/blob/packages/chromium/trunk/unexpire-accelerated-video-decode-flag.patch
-
---- a/chrome/browser/flag-metadata.json
-+++ b/chrome/browser/flag-metadata.json
-@@ -1285,7 +1285,7 @@
- {
- "name": "enable-accelerated-video-decode",
- "owners": [ "media-dev@chromium.org" ],
-- "expiry_milestone": 93
-+ "expiry_milestone": 99
- },
- {
- "name": "enable-accessibility-live-caption",