summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-26 08:10:19 +0100
committerMarius Bakke <marius@gnu.org>2023-01-26 17:14:48 +0100
commitc6ec9c7af9814f84f293f62235eab9d0649751a7 (patch)
treecccf4519995d09d0b2e73a2949c314d56e923a51
parent0e480ca7b60428a62fc4681d7aca6c7c067add42 (diff)
downloadguix-patches-c6ec9c7af9814f84f293f62235eab9d0649751a7.tar
guix-patches-c6ec9c7af9814f84f293f62235eab9d0649751a7.tar.gz
gnu: ungoogled-chromium: Update to 109.0.5414.119-1.
* gnu/packages/chromium.scm (%chromium-version): Set to 109.0.5414.119. (%ungoogled-origin): Update hash. (ungoogled-chromium)[source]: Likewise. [arguments]: Use delete-file-recursively instead of rmdir for compatibility with downstream versions. Remove unused binding.
-rw-r--r--gnu/packages/chromium.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 2c1d86f0f6..94e22d8c21 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -316,7 +316,7 @@
;; run the Blink performance tests, just remove everything to save ~70MiB.
'("third_party/blink/perf_tests"))
-(define %chromium-version "109.0.5414.74")
+(define %chromium-version "109.0.5414.119")
(define %ungoogled-revision (string-append %chromium-version "-1"))
(define %debian-revision "debian/102.0.5005.61-1")
(define %arch-revision "a0b214b3bdfbc7ee3d9004a70494a2b9e3da2c80")
@@ -329,7 +329,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
- "0l07f9221g7q9rmi3drlia40m7dsac26smgh7nnyhfncahzjsc2y"))))
+ "1nb0099gwkhxv3zc184jyvpl5jrrq194pv6yq95nbc27vw6zz7qv"))))
(define %debian-origin
(origin
@@ -492,7 +492,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "0pcfaj3n3rjk4va9g0ajlsv1719kdhqcnjdd4piinqxb4qy27vgd"))
+ "0bdyb14v12izxkldq27jx532p0bid3wdwfpd1mwm7jqswxgfzkfb"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
@@ -671,7 +671,7 @@
;; The unbundling script leaves behind an empty pyyaml directory
;; which prevents the code that tries to use it from falling
;; back to the pyyaml provided by Guix.
- (rmdir "third_party/pyyaml")
+ (delete-file-recursively "third_party/pyyaml")
(substitute*
"third_party/breakpad/breakpad/src/common/linux/libcurl_wrapper.h"
@@ -750,9 +750,7 @@
(string-append mesa-lib "/libGLESv2.so.2"))))))
(add-before 'configure 'prepare-build-environment
(lambda* (#:key native-inputs inputs #:allow-other-keys)
- (let ((c++ (search-input-directory (or native-inputs inputs)
- "include/c++"))
- (node (search-input-file (or native-inputs inputs)
+ (let ((node (search-input-file (or native-inputs inputs)
"/bin/node")))
;; Define the GN toolchain.
(setenv "AR" "llvm-ar") (setenv "NM" "llvm-nm")