summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-04-17 10:14:55 -0400
committerLeo Famulari <leo@famulari.name>2016-04-18 15:45:41 -0400
commitc21a25627241468cb3181dc50c5abfd205bca05d (patch)
treed11e0f134777ced181de55dbf9ee010e767cebd1
parentcf1b55bd32f8cf44aa91712c8d159ad7ca515e4f (diff)
downloadguix-patches-c21a25627241468cb3181dc50c5abfd205bca05d.tar
guix-patches-c21a25627241468cb3181dc50c5abfd205bca05d.tar.gz
gnu: Add dillo.
* gnu/packages/dillo.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu-system.am2
-rw-r--r--gnu/packages/dillo.scm63
2 files changed, 65 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 2b4c71d11f..d58155a1b5 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -4,6 +4,7 @@
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
# Copyright © 2013, 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
+# Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
#
# This file is part of GNU Guix.
#
@@ -90,6 +91,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/dejagnu.scm \
gnu/packages/dico.scm \
gnu/packages/dictionaries.scm \
+ gnu/packages/dillo.scm \
gnu/packages/disk.scm \
gnu/packages/djvu.scm \
gnu/packages/dns.scm \
diff --git a/gnu/packages/dillo.scm b/gnu/packages/dillo.scm
new file mode 100644
index 0000000000..0fd84d9177
--- /dev/null
+++ b/gnu/packages/dillo.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dillo)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages fltk)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages xorg)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public dillo
+ (package
+ (name "dillo")
+ (version "3.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.dillo.org/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
+ (build-system gnu-build-system)
+ (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("fltk" ,fltk)
+ ("fontconfig" ,fontconfig)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libxcursor" ,libxcursor)
+ ("libxft" ,libxft)
+ ("libxi" ,libxi)
+ ("libxinerama" ,libxinerama)
+ ("openssl" ,openssl)
+ ("perl" ,perl)
+ ("zlib" ,zlib)))
+ (synopsis "Very small and fast graphical web browser")
+ (description "Dillo is a minimalistic web browser particularly intended for
+older or slower computers and embedded systems.")
+ (home-page "http://www.dillo.org")
+ (license license:gpl3+)))