summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-11 02:03:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:02 -0400
commitbe672f1f7f0cda28823ef4a4260f39bc845cbabe (patch)
tree54de937541d8d519d6b1efbca75950459ad38154
parentdc71b4f1c65c9f3244f96aaf69b9218825361eda (diff)
downloadguix-patches-be672f1f7f0cda28823ef4a4260f39bc845cbabe.tar
guix-patches-be672f1f7f0cda28823ef4a4260f39bc845cbabe.tar.gz
gnu: bazaar: Obsolete with breezy.
* gnu/packages/version-control.scm (bazaar): Deprecate package. * guix/build/bzr.scm (bzr-fetch): Adjust to use breezy; delete trailing #t. * guix/bzr-download.scm (bzr-package): Replace bazaar by breezy.
-rw-r--r--gnu/packages/version-control.scm41
-rw-r--r--guix/build/bzr.scm8
-rw-r--r--guix/bzr-download.scm6
3 files changed, 9 insertions, 46 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 7351d96600..a43382e94f 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -139,44 +139,6 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
-(define-public bazaar
- (package
- (name "bazaar")
- (version "2.7.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://launchpad.net/bzr/"
- (version-major+minor version) "/" version
- "/+download/bzr-" version ".tar.gz"))
- (patches (search-patches "bazaar-CVE-2017-14176.patch"))
- (sha256
- (base32
- "1cysix5k3wa6y7jjck3ckq3abls4gvz570s0v0hxv805nwki4i8d"))))
- (build-system python-build-system)
- (inputs
- ;; Note: 'tools/packaging/lp-upload-release' and 'tools/weavemerge.sh'
- ;; require Zsh.
- `(("gettext" ,gettext-minimal)))
- (arguments
- `(#:tests? #f ; no test target
- #:python ,python-2 ; Python 3 apparently not yet supported, see
- ; https://answers.launchpad.net/bzr/+question/229048
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-mandir
- (lambda _
- (substitute* "setup.py"
- (("man/man1") "share/man/man1"))
- #t)))))
- (home-page "https://gnu.org/software/bazaar")
- (synopsis "Version control system supporting both distributed and centralized workflows")
- (description
- "GNU Bazaar is a version control system that allows you to record
-changes to project files over time. It supports both a distributed workflow
-as well as the classic centralized workflow.")
- (license license:gpl2+)))
-
(define-public breezy
(package
(name "breezy")
@@ -248,6 +210,9 @@ and protocols. One of the key differences with Bazaar is that Breezy runs on
Python 3.3 and later, rather than on Python 2.")
(license license:gpl2+)))
+(define-public bazaar
+ (deprecated-package "bazaar" breezy))
+
(define git-cross-configure-flags
'("ac_cv_fread_reads_directories=yes"
"ac_cv_snprintf_returns_bogus=no"
diff --git a/guix/build/bzr.scm b/guix/build/bzr.scm
index 86ee11391d..a0f5e15880 100644
--- a/guix/build/bzr.scm
+++ b/guix/build/bzr.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,7 +28,7 @@
;;; Code:
(define* (bzr-fetch url revision directory
- #:key (bzr-command "bzr"))
+ #:key (bzr-command "brz"))
"Fetch REVISION from URL into DIRECTORY. REVISION must be a valid Bazaar
revision identifier. Return #t on success, else throw an exception."
;; Do not attempt to write .bzr.log to $HOME, which doesn't exist.
@@ -37,8 +37,6 @@ revision identifier. Return #t on success, else throw an exception."
(invoke bzr-command "-Ossl.cert_reqs=none" "checkout"
"--lightweight" "-r" revision url directory)
(with-directory-excursion directory
- (begin
- (delete-file-recursively ".bzr")
- #t)))
+ (delete-file-recursively ".bzr")))
;;; bzr.scm ends here
diff --git a/guix/bzr-download.scm b/guix/bzr-download.scm
index 010e0decff..d97f84838e 100644
--- a/guix/bzr-download.scm
+++ b/guix/bzr-download.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2017, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,7 +48,7 @@
(define (bzr-package)
"Return the default Bazaar package."
(let ((distro (resolve-interface '(gnu packages version-control))))
- (module-ref distro 'bazaar)))
+ (module-ref distro 'breezy)))
(define* (bzr-fetch ref hash-algo hash
#:optional name
@@ -64,7 +64,7 @@ HASH-ALGO (a symbol). Use NAME as the file name, or a generic name if #f."
(use-modules (guix build bzr))
(bzr-fetch
(getenv "bzr url") (getenv "bzr reference") #$output
- #:bzr-command (string-append #+bzr "/bin/bzr")))))
+ #:bzr-command (string-append #+bzr "/bin/brz")))))
(mlet %store-monad ((guile (package->derivation guile system)))
(gexp->derivation (or name "bzr-branch") build