summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-06-05 21:22:09 +0530
committerLudovic Courtès <ludo@gnu.org>2024-06-13 11:18:56 +0200
commitbd96132fb9625837e25b837c4d3c7bbfdd290031 (patch)
tree83057e6b0be9bea6193c006d82a6067e622981a3
parent47e909a55408844923b6cb073ebbf25b77b9c2ca (diff)
downloadguix-patches-bd96132fb9625837e25b837c4d3c7bbfdd290031.tar
guix-patches-bd96132fb9625837e25b837c4d3c7bbfdd290031.tar.gz
gnu: Add python-mido.
* gnu/packages/python-xyz.scm (python-mido): New variable. Change-Id: I4bdc6dc6f059dd16c0e0a4152a5e9b5bf84764ee Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 556606b6b4..1bda7e7ab7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -36160,6 +36160,33 @@ terminal. It has red, blue, green, yellow, purple and black/white (default)
colors.")
(license license:expat)))
+(define-public python-mido
+ (package
+ (name "python-mido")
+ (version "1.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mido" version))
+ (sha256
+ (base32
+ "0j63cydiinfyrvlhydzsb00cb7dyvrw3bnhjbdyp63vkxnv2isis"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; This package requires python-packaging~=23.1 which is not yet
+ ;; updated to. As per pyproject.toml, it is required to provide
+ ;; a nice version_info opbject.
+ ;; TODO: After updating python-packaging, fix this.
+ (delete 'sanity-check))))
+ (propagated-inputs (list python-importlib-metadata python-packaging))
+ (native-inputs (list python-pytest))
+ (home-page "https://mido.readthedocs.io/en/stable/")
+ (synopsis "MIDI Objects for Python")
+ (description "This library is for working with MIDI 1.0 ports, messages and
+files.")
+ (license license:expat)))
+
(define-public python-musical-scales
(package
(name "python-musical-scales")