summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-10 21:15:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:40 -0400
commitbd1f8cdf52c8a93630015d70281817a8cae1aa39 (patch)
tree475a372d8ae10805b27b5df3cb5bf29224dc08a1
parentcce678ab8258676e929118f15ab7df3d4601546a (diff)
downloadguix-patches-bd1f8cdf52c8a93630015d70281817a8cae1aa39.tar
guix-patches-bd1f8cdf52c8a93630015d70281817a8cae1aa39.tar.gz
gnu: Add python-untangle.
* gnu/packages/xml.scm (python-untangle): New variable.
-rw-r--r--gnu/packages/xml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index db004c11b6..a0d8d20102 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -2544,6 +2545,35 @@ libxml2 and libxslt.")
(define-public python2-lxml
(package-with-python2 python-lxml))
+(define-public python-untangle
+ ;; The latest tagged release is from 2014; use the latest commit.
+ (let ((revision "1")
+ (commit "fb916a9621175d000a3b0ca9322d3b3ebf8570c0"))
+ (package
+ (name "python-untangle")
+ ;; PyPI currently offers some untagged 1.1.1 version.
+ (version (git-version "1.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch) ;no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/stchris/untangle")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dn2jz9ajncbqx3pdlgqaxmngl6pdiaz03nj8mkddasckdq9lbrh"))))
+ (build-system python-build-system)
+ (arguments (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "tests/tests.py")))))))
+ (home-page "http://0chris.com/untangle")
+ (synopsis "XML to Python objects conversion library")
+ (description "@code{untangle} is a tiny Python library which converts an
+XML document to a Python object.")
+ (license license:expat))))
+
(define-public python-xmlschema
(package
(name "python-xmlschema")